0

I need to play a video file with ffplay in fullscreen mode. The original file has 720x576 resolution, my display is at 1920x1080.

When I launch ffplay as ffplay "filename.avi" and upscale it by maximizing its window, the resulting video looks pixelated. I think this is related to default image scaling algorithm used by ffplay.

When I launch it as ffplay "filename.avi" -vf scale=1920x1080:sws_flags=lanczos+accurate_rnd+full_chroma_int+full_chroma_inp and maximize the window, the result looks much better (anti-aliased, smooth edges), but CPU usage is at 25%.

At the same time, when I watch the same video in Windows Media Player, the result is as good as when upscaling the video in ffplay, but CPU usage is less than 5%.

How can I achieve the same result with ffplay?

Maybe it's because Windows Media Player upscales the video with GPU? If so, can ffplay use GPU too?

UPD: Does https://stackoverflow.com/questions/29037324/ffmpeg-frame-to-directx-surface-hardware-accelerated have something in common to my question?

2

FFPlay does not support Hardware Acceleration. This two year old feature request does not appear to have gotten much attention.

You can enable Hardware Acceleration for FFMPeg overall, but it does not appear to use it in ffplay.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.