I've tried several times over the last few days to get Windows 10 Professional up and running properly on my 2014 MacBook Pro. After each install I've tried I've hit issues immediately after installing the latest bootcamp drivers and software.

Approximately 60 seconds after boot I get a BSOD with "KERNEL_SECURITY_CHECK_FAILURE" and checking the minidump logs the only driver in the stack is actually the NT kernel. If I don't install Bootcamp then things seem to be solid, but I'm missing support for both my keyboard function keys (which is annoying since I can't change the brightness etc. easily) and worse, the trackpad. I don't have any way of right clicking right now!

I didn't have WiFi until I found and installed the Broadcom drivers from one of the bootcamp folders, but it seems that none of the Apple drivers actually do anything without running the bootcamp setup. Unfortunately that appears to be an all or nothing affair and I've been unable to work out what's the cause of the BSODs.

Does anyone know a good way of trouble shooting this? Installing Bootcamp makes it impossible to do much because of the BSODs, and safe mode works but doesn't really help me work out what's going on.


have you tried booting with safe mode and running Driver Verifier Manager? heres a link on how to use it. http://www.thewindowsclub.com/windows-driver-verifier-device-manager. it also explains how to fix your problem with device manager.

  • 1
    This may theoretically answer the question, but it would be preferable to include the essential parts of the answer here, and provide the link for reference. Apr 10 '17 at 0:25

I had your exact issue and let me say it was frustrating. To get touchpad functionality that isn't managed by bootcamp's driver manager, and will allow you to use your laptop regularly - like not safe mode or with BSOD's, go online with your broadcom-enabled wifi and download and install Trackpad++; a dependency of Trackpad++ appears to be Power Plan Assistant - so you might want to download and install that as well like I did.

I had previously used Trackpad++ before, but that was on top of bootcamp's driver manager so it was unnecesary, however, now that the latter completely breaks the build it's finally the former's time to shine! I documented what I did at https://acsweb.ucsd.edu/~pjma/blog/2019/09/25/.

  • Welcome to Super User! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference.
    – Mokubai
    Sep 26 '19 at 17:36

Had the same problem. Workaround: Under the folder BootCamp\Drivers\Broadcom rename the subfolder called BroadcomBluetooth to e.g. XBroadcomBluetooth. Now rerun Setup.exe.

For me this allowed bootcamp to complete installation, presumably installing all but the faulty broadcom bluetooth driver and solved an issue with audio crackling.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.