15

Is there a way to have Chrome save username/password for proxy servers, so I don't have to type them in every time I start it up?

3

Edit: in newer versions of Chrome, it should use your system proxy settings by default. Alternately, there is a command line option --proxy-server=host:port that should work.

Previously: Click the little gear icon in the upper right corner, select "Options". Go to the tab "Under the Hood", and click "Change Proxy Settings". Make sure "Manual Proxy configuration" is selected and fill in your proxy. Click the "Details" button to enter your user and password.

  • 4
    In Windows , at least in XP which i'm testing what you say in, when you click "change proxy settings" it brings up the "Internet Properties" screen which is the same oen IE uses. There is no "Manual proxy configuration screen". Maybe there is in Ubuntu. Perhaps what you say is Ubuntu specific community.screen-scraper.com/files/media/screenshots/… – barlop Apr 1 '12 at 5:51
  • 1
    @barlop It's been changed in Ubuntu as well now to use the system settings. Should be more consistent that way. – Matthew Talbert Apr 2 '12 at 1:36
  • 2
    @MatthewTalbert Not consistent across systems though. Firefox uses its own settings and works well. – barlop Apr 2 '12 at 4:49
  • 5
    Unfortunately I can't change my proxy settings because "Google Chrome is using your computer's system proxy settings to connect to the network." And sometimes that works, but sometimes it asks me for my credentials a 1000 times. It remembers them, but it still asks me to click a button before it can show me that very same dialog again. It's utterly useless. – mcv Jul 7 '14 at 7:48
  • 3
    This answer doesn't work. Why is it selected? – Pacerier Sep 15 '15 at 9:00
4

To save login and password, go to the Options, and Personal Stuff. Select the option Offer to save passwords.

After, close the browser, open again, and put your user and password. To verify if it works, close and re-open one more time. If Google Chrome loads the proxy login screen, with user and passwords already loaded, this workaround worked well.

3

I had the same when I have upgraded my chrome to version 41.

The easy way to get rid of this is by adding one of these Chrome extensions "Proxy Auto Auth" or "Proxy Helper". Just add one of these extensions to your chrome and save your proxy credentials. After that you wont be asked for entering your proxy details again and again when ever you open the chrome.

  • <a href="chrome.google.com/webstore/detail/proxy-auto-auth/… Auto Auth</a> works well. Though in my case, the Microsoft ISA NTLM Auth proxy is load-balanced between two Proxies, so I'm still presented with the authentication pop-up, but once I hit "Cancel", it continues to work. – h q Apr 6 '15 at 8:28
0

For me Chrome knew which proxy server to connect to using the automatic settings it would just never prompt me to save the password.

I found that after ensuring that the password wasn't saved incorrectly (using the manage saved passwords feature) that Chrome would only prompt me to save if I navigated to a domain which chrome had not recently resolved. I'm not sure if it somehow caches that it shouldn't prompt you for recent domains but this got Chrome to offer to remember to save the password, after that you only need to hit enter when it prompts you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.