Is there a way to enable the hardware GpuMemoryBuffer in Chrome under Windows?

My desktop computer has an AMD FirePro W7100 graphic card, with the DirectGMA technology. Is there a way to use that?

Any chance to use a workaround? What about the zero-copy? I run Chrome with the following flags:

--canvas-msaa-sample-count=0 --enable-gpu-memory-buffer-video-frames --enable-gpu-rasterization --enable-hardware-overlays --enable-native-gpu-memory --enable-zero-copy --force-gpu-rasterization --gpu-rasterization-msaa-sample-count=0 --ignore-gpu-blacklist --num-raster-threads=6

But all the GpuMemoryBuffer Status fields are "Software only". The --enable-gpu-memory-buffer-compositor-resources flag causes screen flicks.

I need the maximum video performance because i am developing a videowall controller. When I show 4 fullhd videos uncompressed simultaneously all runs smooth, but adding another one the performance is heavily reduced. By nine the FPS drops to 20.

All the videos are from capture cards that not compress in any way the signals.

The CPU is an hexacore [email protected] with 8Gb DDR4 in dual channel.

Many thanks in advance.

2 Answers 2


GpuMemoryBuffer is supported on MacOSX, ChromeOS and Android only


Sorry, can't comment, but will share my experience. After using --enable-native-gpu-memory-buffers, chrome://gpu/ stopped showing Native GpuMemoryBuffers: Software only. Hardware acceleration disabled and began to show Native GpuMemoryBuffers: Hardware accelerated.

Still, all GpuMemoryBuffers Statuses are displayed as Software. I can't talk about performance impact yet. But this controversy (or is it?) seems strange to me.

As for you setup, The amount of data DDR4 is able to handle is about, say, 40-70Gb/s on dual channel. High-end video card ~400-500Gb/s

You are pumping 1920*1080*3*9 = ~56Gb/frame.

Oh, I missed the date of post.. Anyway. those time my video card was pretty good with its 100-150Gb/s. So even 20 FPS look phenomenal to me.

So my incompetent conclusion just from common sense tells me that hardware becomes bottleneck, not chrome options.

And, considering this post is so old, could you please share the outcome?

  • Enabling the flag didn't work for me on Win7. May 8, 2018 at 17:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .