I have been playing with the new linux subsystem on Windows and somehow i have broken it and now most of Ubuntu's internals (apt-get,dpkg, etc) don't work. Everything i try something i get the same message...

    Setting up udev (204-5ubuntu20.19) ...
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: No such file or directory
runlevel:/var/run/utmp: No such file or directory
 * udev requires devtmpfs support, not started
invoke-rc.d: initscript udev, action "restart" failed.
dpkg: error processing package udev (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of systemd-services:
 systemd-services depends on udev (>= 175-0ubuntu23); however:
  Package udev is not configured yet.

dpkg: error processing package systemd-services (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpam-systemd:amd64:
No apport report written because the error message indicates its a followup error from a previous failure. libpam-systemd:amd64 depends on systemd-services (= 204-5ubuntu20.19); however:
  Package systemd-services is not configured yet.

dpkg: error processing package libpam-systemd:amd64 (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas how to fix this?

  • Is there a "reset" or uninstall/reinstall option? That's probably the easiest & fastest. Any idea what you did to have this happen? Erase root (/) or something?
    – Xen2050
    Apr 13, 2016 at 2:47
  • 1
    Per AskUbuntu, try: sudo apt-get install upstart-sysv for a quick fix - that post has a link to the "recommended" fix as well. Not sure it's the same problem, but it looks like it might be related.
    – tanner
    Apr 13, 2016 at 4:03
  • 1
  • 1
    @ Ramhound I did not ask how to reinstall Bash on Ubuntu on Windows 10, i asked how to fix the problem. I have never had this problem in actually Ubuntu. If going Nuclear is fixing problems, then i don't want to be around when they fix global warming Apr 15, 2016 at 20:19
  • 1
    @Ramhound But i doesn't answer my question. That's like saying "reinstall windows every time you get an error message" or "buy a new car every time you hear a noise".... It solves to problem but its not a practical solution. Apr 15, 2016 at 20:26

4 Answers 4


Warning, this process will restore Lxss to initial config

To reinstall the Lxss open Windows cmd as administrator and run:

C:\WINDOWS\system32>LxRun.exe /uninstall


C:\WINDOWS\system32>LxRun.exe /install
  • 1
    I did not mark this as the answer because it is a nuclear approach to the problem i was having. Yes it would fix it (in theory, i did not try), but the way i fixed it correct my exact problem with out going nuclear. But if i continue to have problem i would recommend this approach if you want to save hours. In the future though i doubt people would want to reconfigure there Linux Subsystem every time something goes wrong. Apr 15, 2016 at 20:09
  • The problem is with the Ubuntu subsystem itself. Reinstalling it won't fix anything Apr 22, 2016 at 6:44
  • 2
    @PanagiotisKanavos for those of us finding the question via google (having made a mess in our installs): I can assure you the answer is still very much appreciated! Apr 30, 2016 at 20:15
  • 2
    You guys are right, this isn't the answer and we should use this as last option.
    – Jonas
    May 5, 2016 at 2:41
  • I'm getting a Access is denied. when I run C:\WINDOWS\system32>LxRun.exe /uninstall even if the cmd session is being run "as Administrator". Any ideas?
    – fredrik
    May 17, 2016 at 13:16

Fixed it.


apt-get remove upstart


apt-get remove udev


apt-get autoremove

and it all seems to be working now.

  • 1
    Must have installed when i installed x11 (a too new version) ... btw x server has to run in windows not in the linux subsystem. and then you forward the application by running DISPLAY=0: firefox Apr 13, 2016 at 4:50

The official response from microsoft


This is an issue that everyone will start seeing. We need to add something on this in our official docs.

As @nuclearmistake points out, udev is something that breaks in apt-get but the errors should not cause any issues in WSL. We have reached out to Canonical on this one asking for the best solution and they recommend the following changes:

Write the following to /usr/sbin/policy-rc.d

#!/bin/sh exit 101

chmod +x /usr/sbin/policy-rc.d

dpkg-divert --local --rename --add /sbin/initctl

ln -s /bin/true /sbin/initctl

I have tried this one myself and it looks to work quite well.


Here is a more targeted solution. Create a script named /usr/sbin/policy-rc.d (nano /usr/sbin/policy-rc.d) with the following contents:

case "$1" in
    udev|systemd-logind) exit 101;;

Save and exit (Ctrl+O Ctrl+X). Mark the script as executable (chmod +x /usr/sbin/policy-rc.d). This script tells dpkg not to attempt to start udev or systemd-logind.

You will then be able to complete the previously failing dpkg configuration step (dpkg --configure -a).

  • 2
    This is an answer that could be improved by explaining what happened, what the "somehow" in the question actually was and how this series of steps addresses it. Here is one pointer to use. Here is another.
    – JdeBP
    Apr 19, 2016 at 12:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .