49

On the new Windows 10 insider build 14316, I haven't been able to use Ctrl + V (shortcut for paste) on the new Bash on Ubunbu on Windows app. Has anybody else had this issue? Any solutions?

I have edited the app's properties to enable control shortcuts and insert. Also, I have tried Ctrl + Shift + V and Shift + Insert and neither work.

  • 1
    Does Ctrl+Shift+V work? That's what the shortcut is in many Linux terminals. Otherwise, I seem to remember that middle click pastes in cmd (but I don't know for sure). – Tanner Filip Apr 13 '16 at 3:58
  • Ctrl + Shift + v doesn't work either. And I don't have a middle click. – Sergei Wallace Apr 13 '16 at 3:59
  • if the original bash doesn't support if, Windows 10 will also not support it. Does it work in a real Ubuntu? – magicandre1981 Apr 13 '16 at 4:33
  • 1
    I don't know, I've never used the real Ubuntu. I have Windows, and hence was thrilled when the announced that they would have Bash. It just sucks not being able to copy and paste quickly. They support it for the command prompt though, so maybe they just haven't added it for their bash shell yet, or forgot. Or it's a bug, idk. – Sergei Wallace Apr 13 '16 at 5:17
  • This question may explain why. Remember, you are essentially running Linux, so it will behave differently than you may expect if you're only used to how Windows works. – heavyd Apr 13 '16 at 5:47
43

Why don't you guys just Right Click? here is how to enable copy and paste:

  1. Go to the top of the bash window, right click, go to properties
  2. Check the box that says Quick edit Mode, and you are set!

    Copy and Paste Enabling on Bash for Windows 10

Good day!

-- Activate Quick Edit mode, then mouse left-click is select text, right DOUBLE-click is PASTE

  • 9
    Helpful but I would say that "QuickEdit Mode" is not a hugely transparent label for saying "allow right click paste" so not surprising it was missed. – Nate Sep 28 '16 at 9:45
  • 24
    My reason for not right clicking is simple: I don't want to move my hand to the mouse if I can avoid it. Keyboard shortcuts exist for a reason, and should be maintained across the platform (I don't really care what the shortcut is for copy&paste, as long as there is one). – Jed Daniels Jan 11 '17 at 18:28
  • 6
    Right click is not ctrl+v... – nicowernli Mar 1 '17 at 21:47
  • 2
    Doesn't work for me even though my settings were already set up as in the screenshot. Asking why don't we just right click is kind of annoying. The question was about getting the keyboard shortcut working -- you're saying why not just not use the keyboard :-[ – jcollum Jun 28 '17 at 15:07
  • 5
    This is not a real solution to the issue. – Zoey Jul 1 '17 at 22:36
10

The main issue, I believe, is that cmd.exe isn't dealing well with the bash environment. By itself the new cmd.exe actually does support Ctrl+v but whilst running bash, it doesn't.

My workaround is to use ConEmu. It's much superior to cmd.exe alone and even gives you color highlighting when running bash. I've tested it and Ctrl+v does work. As a nice plus, you get a tabbed terminal.

  • 1
    I downloaded it. How do I configure Bash to use ConEmu instead of the normal command prompt? – Sergei Wallace Apr 17 '16 at 16:01
  • ConEmu is sort of a wrapper around cmd.exe. Just by running the plain cmd.exe within ConEmu should allow you to paste by using CTRL+V. – Tiago Espinha Apr 18 '16 at 8:56
  • @spwallace if you've installed bash before ConEmu, the first time you start ConEmu (which I am doing right at this very moment) the fast configuration offers to "Choose your startup task or even a shell with arguments" and bash is there. But also once you started ConEmu, the green plus menu besides the search bar also offers all sorts of shells. – chx May 5 '17 at 1:01
  • ConEmu solved the Ubuntu Bash "Ctrl + V" problem for and a nice thing is that ConEmu is Open Source Software (BSD license). Plus it fixes the awful "directory path blue" that is just unreadable on black background. – Alex Jul 15 '17 at 12:29
  • Thank you. I've installed ConEmu and it's looking great so far. – Manachi Sep 12 '17 at 7:47
4

As far as I know there's no 'good' solution out there (quickedit paste doesn't seem to work).What I would suggest is this: create an autohotkey script:

SetTitleMatchMode, 2
#IfWinActive, bash
^v::
SendInput {Raw}%clipboard%
return
  • I have ConEmu running but I do not want to use Ctrl + V because that's used by nano so I used +^v::. Also, since ConEmu doesn't always have bash in the window, I used #IfWinActive ahk_exe ConEmu64.exe – chx May 14 '17 at 6:54
2

As we figured out in the comments, the Paste entry in the window's system menu only activates after pressing Ctrl+V once, which is unusual. After that, though, you can use the sequence Alt+Space, E, P. (Courtesy of this Stack Overflow answer by Nescio.) That's not optimal, but it works.

If the Bash on Ubuntu on Windows window has a Properties entry in that menu, you might be able to check the "QuickEdit Mode" box on the Options tab to allow right-clicking in the window to count as a paste.

  • weird... Alt+Space doesn't bring up the menu like it should either. – Michael Feb 8 '17 at 4:57
  • @Michael same here; this bash in windows thing is pretty anemic – jcollum Jun 28 '17 at 15:06
2

Starting with at least Windows 10 Insider build 17643, you can use Ctrl+Shift+C/V as Copy/Paste if you enable it in the bash options:

enter image description here

This feature is part of the October 2018 Update (1809 - Build 17763).

  • any update on when this is coming to public? – Felix Böhme Dec 12 '18 at 16:01
  • @FelixBöhme Felix, this is part of 1809 October 2018 Update Build 17763 – magicandre1981 Dec 12 '18 at 20:19
1

The problem is not specific to "BASH on Ubuntu". All Windows commandline windows experience this including cmd and powershell. Access the window menu under the icon in the top left (another answer mentioned alt+space, this opens the window menu). Choose defaults. Enable QuickEdit mode.

By default, in QuickEdit mode, highlighting copies and right click pastes. (Before Win 10, it still doesn't get you ctrl+c and ctrl+v).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.