3

Just recently, git in Cygwin has not been behaving correctly. When I try to run a command like git pull it does not show anything about the pull. The git status command works just fine and shows the appropriate information.

However, all of this works just fine and dandy in Git Bash and Git CMD.

The only thing I've done recently that could have affected Git was install Chef and installed Git for Windows because I couldn't get Git to work in cmd.exe because of an error cygcrypto 1.0.0 dll is missing.

Prior to all of this, git worked flawlessly in Cygwin for several months.

Here is a picture of my git command outputs. The top window is Git Bash, and the bottom is Cygwin.

stract git pull output file I had to upload and share it on my Google Drive because the output was too large for any paste hosting site. Pastebin is blocked here at work so I may try to upload it there later.

Picture

Here is a picture of what's happening after I've removed git from Cygwin and reinstalled it. enter image description here

  • git pull -v might reveal something useful (though probably not). After that, you might try strace git pull. I'm guessing your git installation got corrupted somehow, so you might try just reinstalling the package as well. – jjlin Apr 13 '16 at 17:55
  • @jjlin git pull -v showed up blank just like git pull. I ran stract git pull and directed the output to a text file. I added a link to the text file for anyone who would like to read it and hopefully pick up some clue. I'm out at work for the rest of the day so I'll be sure to try any suggestions tomorrow. – DrZoo Apr 13 '16 at 18:00
  • Small update. I tried to reinstall git in Cygwin and uninstalled Git for Windows, but I still have the same result. – DrZoo Apr 14 '16 at 18:12
  • Next update, I completely removed git from Cygwin and reinstalled the git packages. I have a slightly better situation, but not quite. Now I get error: fetch died of signal 13 when I try to do a git pullA picture is attached in the question body. – DrZoo Apr 14 '16 at 18:51
  • Your trace "--- Process 3428 exited with status 0xc0000139" suggest you have a broken cygwin. Follow suggestion on cygwin.com/problems.html. and ask help on cygwin mailing list – matzeri Apr 15 '16 at 16:02
1

What seems to fix the problem is to re-run the Cygwin installer and install a new package. When I fixed my problem I installed some new random package, but in the comments above Izzy installed the openssl-devel package.

After re-running the Cygwin setup the problem was fixed.

Note: You can try this method without adding any new packages too. Just let Cygwin go through the setup process again. Doing this does not blow your Cygwin away and start over. It seems to just overwrite the already existing files, and add any new packages you may have added.

  • In my case, re-running Cygwin was not even involved – git started working again straight away. It cannot hurt to check for other outdated stuff: In my case, Curl was still broken afterwards due to a version mismatch (Curl was newer than libcurl). Updating libcurl brought back the original issue. Checking and updating the other ~50 pending updates fixed it again :) – Izzy Jan 10 '17 at 18:14
  • @Izzy sorry I think I misunderstood how you installed your openssl-devel package. I added my package by running the installer again. How did you go about installing openssl-devel? – DrZoo Jan 10 '17 at 18:19
  • Ah, my fault. I'm using Mobaxterm, which ships with an integrated package manager. For "plain Cygwin", this would correspond to apt-cyg install AFAIK (though I used the GUI). – Izzy Jan 10 '17 at 18:22
  • 1
    @Izzy ohhhh ok. Same problem, different terminal, same steps to resolve. I understand now, thanks! – DrZoo Jan 10 '17 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.