0

I recently installed Debut Video Capture (from NCH software) and now some of the application icons in explorer are corrupted, just showing a generic "folder" icon. So far I've found this has affected:

.bmp
.doc
.jpg
.png

but there may be others. Not all file type extensions are affected, for example .txt correctly shows a Notepad icon and .mp4 shows the VLC icon.

JPG file type corrupted

MP4 file type ok

The shortcuts themselves work fine, with the correct "Open" and "Edit" functionality. I've tried the following:

* edited registry to manually remove the NCH software additions to known file types
* changed file type association to different application then back again
* rebuilt icons in TweakUI
* killed and restarted Explorer from Task Manager
* rebooted entire PC

None of these actions has helped. The shortcuts work fine (ie. when clicking.doc, Microsoft Word runs correctly)...but still continue to display the wrong icon. Anybody know how to force Windows to update or re-cache these?

* UPDATE *

After digging in the registry, the icon being displayed in Explorer (for a .png file) is as follows:

[HKEY_CLASSES_ROOT\pngfile\DefaultIcon]
@="%SystemRoot%\\system32\\shell32.dll,19"

ie. the index[19] icon in shell32.dll (see next image). Changing the application loading a PNG does not update this.

PNG default icon association

  • The list of affected icons is growing as I use the PC more eg. .zip and .cab files. Now also tried TweakUI > Repair > Rebuild Icons => no joy, still corrupted. Lots of icons are still ok, like .pdf. – AlainD Apr 14 '16 at 12:38
  • Deleting the hidden file Iconcache.db in C:\Documents and Settings\<user>\Local Settings\Application Data has also not helped. The file gets re-created after rebooting...but the affected icons are still corrupted. Changing the colour depth in Display properties has also not helped. – AlainD Apr 14 '16 at 14:42
0

This manual solution worked for me on this particular issue, though it would be far more satisfying if Windows would use the icon from the application selected to open the file type. You will need an uncorrupted Windows PC to copy settings from.

Step 1: Identify an affected file type. In this example, I will use .jpg.

Step 2: On the uncorrupted Windows installation, open regedit (registry editor) and navigate to:

HKEY_CLASSES_ROOT\.jpg

Step 3: Note the (Default) key, in this case jpegfile. This points to the actual registry key that decides which icon to display (and which application to open, etc).

Step 4: Navigate to:

HKEY_CLASSES_ROOT\jpegfile\DefaultIcon

Step 5: Copy the value of (Default). In my case, this entry was shimgvw.dll,3.

Step 6: On the corrupted Windows installation, open regedit and navigate to:

HKEY_CLASSES_ROOT\jpegfile\DefaultIcon

Step 7: Note the current value of the (Default) key. In my case, this had been corrupted to %SystemRoot%\system32\shell32.dll,19. You may find that most of your corrupted icons will have been changed to this.

Step 8: Change the value of the (Default) key to the value copied in step 5 (shimgvw.dll,3).

Step 9: Close regedit and load the Windows Task Manager.

Step 10: On the Processes tab, select explorer.exe and then End Process. Now move to the Applications tab, select New Task..., type explorer and hit the RETURN key.

You should find that .jpg file type icons are now restored. Repeat for other corrupted file types.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.