I have a Zyxel P660HW-t1 v2 router (which has a DSL port) and a WRT54GL router (which does not) and the exact same situation as in this thread (UPDATE: the connection between both devices is the important part, since I have been able to set the zyxel router to act as bridge by itself quite nicely. I have accessed my internet connection directly through a PC using PPPoE without any problems, the issues arise when I try to connect the WRT54GL router between the zyxel "modem" and my PCs).

I've been trying to use my Zyxel P660 as a modem only:

  1. Setup P660 to bridge mode.
  2. Changed WRT54GL's IP address to to avoid a conflict on the network.
  3. Configured the PPPoE settings as required on WRT54GL.

The thing is that when I connect the Zyxel modem/router on the WRT54GL's internet port the light doesn't turn on. I can confirm that this port has been working ok, so I'm not really sure what's going between the devices. I checked several settings such as IPs, tried disabling DHCP on Zyxel/Linksys, Firewall on both and still nothing. Also, I tried connecting Zyxel directly to a computer in bridge mode and dialed successfully.

I have even posted a question here before, thinking that what I asked there was the only thing I needed to get things done. Unfortunately it wasn't, and the guy that solved his issue didn't give enough details in his post (and is quite unlikely to give more details since he was an anonymous user).

For one, I don't know how to do this part:

connected to the Zyxel through telnet and forced LAN port 1 to be at 100mb as well

I can't find the option that does this on the zyxel router. Not through telnet or the web admin.

Can anyone help me solve this?

EDIT: I noticed, in the end, that the router takes a while to tell you it "connected" to the WAN. So a bit of patience may be needed before making hasty assumptions. My case was possibly because of this, in the end.


You should be able to configure your P660 in bridge mode as explained in the manual. Once configured in bridge mode configure you WRT54GL to obtain the WAN IP address and DNS automatically. Also, make sure that the WRT54GL's LAN IP address is not the same as the IP assigned to the P660 ( if following the guide, so something like should work). Make sure the DHCP server is turned on on the WRT54GL and you should be good to go.

  • That much I did, just as the original poster specified. I was, as well, able to connect the Zyxel directly to a computer in bridge mode and dial successfully, but through the router I have not been able to. – Kenji Kina Feb 9 '10 at 16:31
  • Does the router get a WAN IP from your ISP? Can you ping your router's LAN IP? WAN IP? WAN default gateway? – heavyd Feb 9 '10 at 16:42
  • The router does not get a WAN IP. I can ping my router's LAN IP, but, again, it has no WAN IP to ping to. I am not sure what you mean about the WAN default gateway (I am not sure if this has any bearing with the current situation, but I my ISP has me connecting through PPPoE, which I am trying to configure in my router). – Kenji Kina Feb 9 '10 at 17:56
  • I have updated the question to better reflect the issue. I apologize for the previous lack of accuracy. – Kenji Kina Feb 9 '10 at 18:03
  • WAN default gateway would only be applicable if you got a WAP IP from your ISP. I seem to remember trying to do the same thing you are doing but with an Actiontec DSL modem and not ever getting the PPPoE to authenticate. If you connect a computer directly to the modem it works, correct? Are you doing the PPPoE on the computer? Have you tried with a different computer as well? – heavyd Feb 9 '10 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.