3

Description of Problem

Recently I have been having trouble connecting to the internet using wireless, but I am able to connect via a wired connection. I'm using a TP-Link Archer C7 wireless router as an access point, and it has been working fine for around 3 months without requiring a reset. Recently I have been unable to connect when using this wireless connection, and i'm a bit puzzled as to what the cause is.

  • DHCP and DNS servers are hosted locally, but I have not been able to find any indication of a cause for my lack of connection.
  • If I connect via Ethernet to the Archer C7 I am instantly able to connect to the internet, and achieve great download/upload speeds. However any attempts to connect to the internet while using wifi have proven to be futile.
  • No changes have been made to the running configuration of the primary router for 2 - 3 months.
  • No changes were made to the Archer C7 router for 1 - 2 months.

Network information of a device connected to wireless has been provided below. Any ideas of what the possible cause of this newly arisen behavior that prevents me from accessing the internet while on wireless? Let me know if I can provide any additional information, and thank you for trying to help.

Attempts to fix the issue

  • I turned the DHCP server on the archer C7 on, set the DHCP server in the archer C7 router outside of the scope of the domain DHCP servers, and attempted to use that information to connect. That also did not produce any changes, but it was interesting to note that any devices connected to the archer C7 via a wired connection were assigned an IP address within the scope of the domain DHCP servers, rather than utilizing the DHCP server present within the archer C7. Wireless clients were able to use the DHCP server in the archer C7, but still not able to connect.
  • Factory reset the router, and configured it from scratch with no luck. When I set up the router I disabled DHCP, firewall, nat, and any forwarding when configuring the Archer C7 router.
  • As a test I removed the Archer C7 router from the network, turned it off to prevent any possible wireless interference, and configured a second router as an access point with similar configurations from the first. Still, I was unable to connect to the internet.
  • I have also tried to remove the security on the wireless with no distinguishable effect.
  • I am able to ping from the Archer C7 to the main router, and from the Archer C7 to the DNS/DHCP servers with no packet loss. Any device that is connected to the wireless network experiences severe (40% - 80%) packet loss when attempting to ping the router (192.168.1.1) or DNS/DHCP servers (192.168.1.11,192.168.1.12).
  • I have restarted the DHCP and DNS servers on both domain controllers in the network, but I have noticed no difference as a result.
  • Also as a note I have attempted to manually set the network information, but am still not able to access the internet.
  • I have tried to set the DNS servers to 8.8.8.8 in the network information of the connected wireless device with no luck.
  • I have also tried to move the Archer C7 to utilize a different Ethernet port, and changed the Ethernet cable that was being used.
  • I have tried to connect to the wireless access point with multiple windows 7 computers, iPads, Macs, and android phones. No luck. Interestingly enough I was able to temporarily gain access to the internet on a mac, but that was short lived.

Peculiarities

  • Sometimes when I attempt to connect to the wireless network DHCP works properly and assigns the correct information, as detailed below. Yet other attempts to connect to wireless produce network information with an IP beginning with 169, and a subnet of 255.255.0.0, which to me suggests that the router is unable to reach the DHCP server to provision the correct information.
  • I am able to ping from the Archer C7 to the main router, and from the Archer C7 to the DNS/DHCP servers with no packet loss. Any device that is connected to the wireless network experiences severe (40% - 80%) packet loss when attempting to ping the router (192.168.1.1) or DNS/DHCP servers (192.168.1.11,192.168.1.12).
  • My boss has his a mobile wireless hot spot, which is able to operate inside the office, but has been running slower than usual lately. Could wireless interference be causing the problem?

Network Information

  • Network information (For device connected to wireless): IP: 192.168.1.22 Subnet: 255.255.255.0 Router: 192.168.1.1 DNS: 192.168.1.11, 192.168.1.12

  • Network information (Actual addresses): Router: 192.168.1.1 Subnet: 255.255.255.0 DNS: 192.168.1.11, 192.168.1.12 Archer C7: 192.168.1.239

  • The Archer C7 wireless router is connected to a Cisco router via an Ethernet cable that is plugged into the LAN port of the archer C7. The Ethernet connects to a switch, which then connects to the Cisco 2911 router. Everything other device connected to the primary router is operating fine, but it seems as if any device connected with wifi is unable to access the internet.

Previous Research

I have been searching for a few days for the solution to this problem, and I have included some links below to two other posts I have read that were not able to solve the problem I am experiencing. I have read many more, but I am only allowed to post two links.

Update - 4/21/2016

At this point I have the wireless router working, albeit with slightly reduced speeds for the 2.4G.

  • In the router configurations for the archer C7 I disabled WMM in the advanced wireless settings for the 2.4 interface.

  • Set wireless security to WPA instead of WPA2.

  • Modified the beacon interval to a maximum value for 2.4G. Due to disabling WMM the speed on the 2.4 connection isn't as great as it was, but the change seems to slightly help.

I was having issues connecting on certain devices if WPA2 was enabled, and it was only after I changed the security to WPA that devices were able to connect to the wireless router. It was still not possible to access the internet, but after disabling WMM I had no issues connecting. From what I have read it seems that Comcast (my ISP) sends back packets that have been marked as low priority, and having WMM on causing my internet to stall due to the low priority. This isn't a permanent solution, and i'm looking into the two possible solutions below.

  • Creating a separate vlan for archer c7 wireless network and having the Cisco router set the DSCP value on all packets to 0x00. This should enable me to turn WMM back on and still be able to connect to the internet.
  • Flashing the archer C7 to dd-wrt, and then setting the DSCP value in the archer C7. If I go with this alternative I don't have to mess with the main router, and can keep everything more or less contained.

Any thoughts? I'm going to look into both solutions and see what it would take to do both. It seems like flashing to dd-wrt might be the best solution, but I haven't used it before so further research will be required. I'll update with my findings.

  • 1
    People are more likely to read your question if you format it so it is not a wall of text. Please read Markdown help and edit your question to add paragraphs and bullet points ... – DavidPostill Apr 14 '16 at 16:31
  • Thank you, I have edited the formatting as per your suggestions. – MBermejo Apr 14 '16 at 17:03
  • Much better ... ;) – DavidPostill Apr 14 '16 at 17:03
  • Have you tried to connect with other PC/Laptop or phone? , just trying to discard that your pc wifi setup is borked. – arana Apr 14 '16 at 17:16
  • How precisely are the two routers connected to each other? Did you connect a LAN port on one router to a LAN port on the other? – David Schwartz Apr 14 '16 at 17:17
0

After replacing the stock firmware on the Archer C7 with dd-wrt I am experiencing speeds much faster than the stock firmware. Here's what I did to solve my issue.

  • Flashed the Archer C7 router from the stock firmware to dd-wrt.
  • I configured the Archer C7 running dd-wrt as an access point by having the device act as a DHCP relay (options are present to choose between DHCP server, and DHCP relay; DHCP relay seemed to be exactly what I needed) to the local DHCP server, and setting the IP to a value not in use outside the DHCP scope.

WMM is now enabled and i'm able to utilize WPA2 instead of just WPA. I was thinking this might be a DSCP issue related to Comcast, because I experienced the issue on multiple factory reset wireless devices, but now i'm not too sure. For reference I have included a link to the solution I was going to implement in an attempt to set DSCP to a value of 0x00, which should have allowed me to enable WMM and still access the internet. After changing to dd-wrt from the stock firmware this no longer seems necessary.

  • Speed Before: 2.52 Mbps download, 17.27 Mbps upload
  • Speed After: 8.88 Mbps download, 24.44 Mbps upload

Link for Comcast DSCP information: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=176395

Basically I was able to connect using a wired connection, but not using wireless because the DSCP header information sent back to me from Comcast caused slowdowns on wireless interfaces due to the DSCP header specifying packets with the lowest possible priority. This is why I was able to connect to the internet after disabling WMM. Unfortunately my speed was extremely slow, because if WMM is not used speeds are reduced. I replaced the stock firmware on the router with dd-wrt because I would be able to specify the DSCP header on incoming packets, but after configuring the dd-wrt Archer C7 router as an access point this was not necessary.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.