116

I installed the Windows Subsystem for Linux on Windows 10 Insider Preview build 14316. Now I would like to remove it or, better, revert to its factory defaults i.e. as it was when just installed.

I tried, to remove it from the "Turn Windows features on or off" windows, with no luck. I tried, to mark it as "off" in the above windows and delete its files manually located in %USERPROFILE%/AppData/Local/lxss, with no luck.

Has anyone succeeded in removing/resetting the Ubuntu user-mode environment?

155

The following answer only applies to WSL on Windows 10 1703 and 1607. WSL on Windows 10 1709+ can be installed from within the Windows Store UWP application.

If you want to remove and reset the Linux subsystem, open a command line prompt with elevated permissions and enter the following commands:

lxrun /uninstall /full 

lxrun /install

Sources:

  1. https://www.slightfuture.com/technote/lxss-lxrun

  2. Installing Fish Shell on Ubuntu on Windows 10

  3. HOWTO: Ubuntu on Windows | Ubuntu Insights

  • 2
    Godsend, broke it just after installing. – wieczorek1990 Apr 20 '16 at 18:30
  • Yea, broke mine almost immediately trying to install a jdk – James Adam Aug 3 '16 at 0:36
  • 14
    If you get an error code 0x80070091 after trying to install again, go to %localappdata%\lxss and remove all files/folders manually. It should work afterwards. – SeinopSys Aug 3 '16 at 2:34
  • 1
    Use /y option to skip asking prompts. – Biswapriyo Oct 20 '17 at 13:51
  • 1
    anyone know how to do this now that lxrun has been removed? – Matthew Whited Dec 30 '18 at 17:57
1

I was having problems with installing BASH, it would always hang at "Expanding Filesystem...". When I ran

lxrun /uninstall /full

it would error out.

To fix this, I did a reboot. Ran this again as soon as the computer came back up. This worked. Then I found there is an issue related to installing the BASH prompt.

And someone brought up about pagefiles. I have four drives and three of them had pagefiles. I set the pagefile to one drive and set it to be automatically managed. Rebooted the computer. Then I was able to install the BASH prompt for Windows, but instead of using lxrun /install I used

bash.exe -c "ps auxf"

Not the answer you're looking for? Browse other questions tagged or ask your own question.