9

I'd like to immediately return to my desktop after waking from sleep. I've managed to remove the password, but still need to wait and click on Sign in after waking from sleep.

Is there a setting or registry change I can do to disable to sign-in screen completely?

Make sure to test your answer, because the obvious solution of removing a password doesn't get rid of the sign in screen (that used to work in older Windows versions though)

1
  • Good question. This drove me nuts that I'd have to click 3 times with delays in between to get to my desktop. With the answers here, now I've got it down to 2 clicks (one to turn the monitor back on, one to click sign-in button). – mikato Sep 28 '17 at 4:55
2
+50
  1. Right-click Battery icon in the Taskbar, and click Power Options.
  2. Click Change plan settings next to the active power plan.
  3. Click Change advanced power settings.
  4. Click Change settings that are currently unavailable.
  5. Expand Require a password on wakeup and change settings to No.
    Power Options: Require a password on wakeup
  6. Click OK to save the settings.

I use it myself. When I open laptop lid, I see the desktop. After restarting, I have to enter my PIN or password.

6
  • Even though the other answers are correct in the case of a standard power plan; this was actually the solution because I seemed to be using a custom powerplan which overrode the other setting. – Robert Massa Apr 27 '16 at 9:00
  • I don't see an option for "change settings that are currently unavailable" – Fydo Dec 28 '16 at 3:30
  • 1
    @Fydo It looks like in Anniversary update of Windows 10, Microsoft has moved this setting from classic Power Options to modern UI Settings: Accounts → Sign in Options. – Alexey Ivanov Dec 30 '16 at 14:33
  • @AlexeyIvanov I don't see it there (either place). Maybe it is because - "Your account doesn't have a password. You must add a password before you can use the other sign-in options." – mikato Sep 28 '17 at 4:54
  • 3
    @mikato Yes, it's the case. To change the setting in newer versions of Windows 10, you have to have a password. You can create a password for your account, change setting, and then remove your password. I used this as workaround on my shared netbook. – Alexey Ivanov Sep 29 '17 at 11:18
5

If you are

  • using Windows 10 Anniversary Update (version 10.0.14393) or later and using a Microsoft account to log in then the location of the option is somewhere else entirely

or

  • using a later version (the exact version number is not known) with a local login which has a password (you can unset the password afterwards)*

Then go to (Control Panel) or, depending on Windows version, (Action Centre -> All settings) -> "Accounts" -> "Sign-in options" (on the left) -> "Require sign-in" - > Change it to "Never".

enter image description here

* You need to have the password set when you are choosing "Never". It doesn't matter if it was previously set, but the password must currently be set or else the "Never" option will not appear. But after choosing "Never" you can unset the password, and the "Never" option sill works.

1
  • So you need to set a password just to change an option that is actually very useful without a password just to remove the password again? Well that's windows, I guess... – dreua Mar 17 at 20:55
3

Open Run and type "netplwiz". In the dialog box which appears, uncheck the "Users must enter a user name and password to use this computer." option. Click on Apply. An additional popup will appear asking you to enter a username and password which would be used to signing into the desktop. Enter your credentials and click on OK.

Then go to Power Options and select "Don't require a password on wakeup". Restart the system and now you won't have to enter a password or click the sign-in button.

Note: I've tested this on Windows 10 and it works for me.

10
  • Yes, after restarting you get the desktop. But the question states after sleep. – Robert Massa Apr 26 '16 at 16:20
  • 1
    It works on sleep too. – Parth Sarthi Apr 26 '16 at 16:21
  • That's odd, I have these settings but am always getting the sign-in screen after sleep. Which version/edition Windows 10 do you use? – Robert Massa Apr 26 '16 at 18:53
  • Windows 10 Pro Version 1511 Build 10586.164 – Parth Sarthi Apr 26 '16 at 19:00
  • 1
    Actually, just by checking the "Don't require a password on wakeup" in Power Options and changing nothing in "netplwiz" also takes me straight to Desktop without entering a password or clicking Sign In button after waking from sleep. Did you change any other setting in your computer related to this which might be causing this? – Parth Sarthi Apr 27 '16 at 7:36
2

In elevated command prompt:

powercfg /SETDCVALUEINDEX SCHEME_CURRENT SUB_NONE CONSOLELOCK 0

powercfg /SETACVALUEINDEX SCHEME_CURRENT SUB_NONE CONSOLELOCK 0

Reboot.

Source: https://www.tenforums.com/tutorials/11129-turn-off-require-sign-wakeup-windows-10-a.html#option3

0

Run > Control Panel\All Control Panel Items\Power Options\System Settings > don't require a password on wakeup.

If greyed out click "Change settings that are currently unavailable"

1
  • This only removes the password requirement, you still have to click the Sign In button. – Robert Massa Apr 26 '16 at 13:09
0

It seems that for some people (including myself) neither disabling require a password on wakeup nor netplwiz fully disable the login screen after wakeup on Windows 10.
Disabling a password on wakeup removes the need from entering your password after sleep, but Windows 10 may still resume to the login screen that you have to dismiss (even though you no longer have to enter a password).
The netplwiz solution makes the computer automatically log in when starting up the PC, but may not prevent the login screen from showing up when resuming from sleep.
This is the ultimate solution I have found to disabling the login screen when resuming from sleep (assuming you have already disabled password on wakeup, which is described in another answer).

Open regedit
Navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows
Right click on Windows and select New>Key
Name the new key Personalization
Right click on Personalization and select New>DWORD
Name it NoLockScreen
Double click NoLockScreen and edit the value to be 1 and click OK.
Restart the computer, and the lock screen should be disabled when it resumes from sleep.

Credit: http://windows.wonderhowto.com/how-to/disable-lock-screen-windows-10-0162965/

0

If noting works, like in my case, go to right click Start->Power Options->Choose What the Power Buttons Do. Set both buttons to "Sleep" and then click the link above them "Change Settings that are currently unavailable". Uncheck Lock, Save it and try Sleep/Wake again.

0

For me it still didnt work even after Pudergeeks and others suggestion.

My case is a Windows 10 Home edition, with no microsoft account, AND no password.

What I had to do, (in addition to other things from this thread), is go to the following setting:

Lock Screen > click: settings for screen security (near the bottom, in the tutorial I followed it was actually called "Screen saver settings", not sure if they changed the name or if the menu's name was updated)
From there, set the screensaver to "blank". This is what finally did the trick for me. Obviously, "On resume, display logon screen" also has to be disabled. (This was already disabled for me but that didn't initially stop it from actually showing)

Source: https://answers.microsoft.com/en-us/windows/forum/windows_10-power/disable-password-after-sleep-in-windows-10/cf7a7d2b-6927-4ebf-9469-7d06b20d5fc1

Edit: I could change it back to "(none)" afterwards because it's pretty annoying. But for some reason, nothing worked until I touched this menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.