2

I am currently trying to install two operating systems on my PC.

So far I have Windows 10 installed on one hard drive with a secondary hard drive for data storage. On my third hard drive, which is an SSD, I am trying to install a Linux OS. However, there is a problem. When the Linux starts to install, all my USB ports stop working so I am unable to use my mouse and keyboard. I thought this may be due to a disc not done properly or a problem with a specific OS so I tried a few things. I tried three different Linux OSes. On disc, I tried Ubuntu and Kali. The problem occurred when I clicked install or "try before installing". And on bootable USB I tried Linux Mint, however, I was unable to get that to work.

My PC specs:

CPU - AMD Piledriver FX-8 Eight Core 8350 Black Edition 4.00GHz (Socket AM3+) Processor

MotherBoard - Gigabyte 990FXA-UD3 AMD 990FX (Socket AM3+) DDR3 Motherboard

GPU - Gigabyte GeForce GTX 770 WindForce 3x OC 4096MB GDDR5 PCI-Express Graphics Card GV-N770OC-4GD)

RAM - TeamGroup Elite Black 16GB (2x8GB) DDR3 PC3-12800C11 1600MHz Dual Channel Kit (TED316GM1600HC11DC01)

Hard Drive 1 - Western Digital Caviar Green 1TB Internal Hard Drive, 3.5" HDD, SATA III - 6Gb/s, IntelliPower, 64MB Cache, 8ms, OEM

Hard Drive 2 - Western Digital Caviar Green 3TB Internal Hard Drive, 3.5" HDD, SATA III - 6Gb/s, IntelliPower, 64MB Cache, 8ms, OEM

Hard Drive 3 - SanDisk SSD 64 GB SATA III 2.5-inch Internal SSD (This is the one I want to put Linux on)

Thanks for any help, Dan

Edit

Just a note - The most recent OS I am working on trying to install is Linux Kali. This is burned on a DVD and the USB ports work until this point

I am not using a laptop so both the mouse and keyboard stop working.

Edit 2 I took a picture and a get a long list of

[    x.xxxxxx] usb x-x: device descriptor read/64, error -71

enter image description here

  • Did you make sure that you used the USB version of the ISO? – Steampunkery Apr 17 '16 at 16:40
  • @Steampunkery I'm pretty sure I did. I think the problem was I didn't make a bootable USB properly. Anyway, that is not the main problem. I would like to find out why all the USBs stop working past clicking the first option - when the DVD launches a program – Dan Apr 17 '16 at 16:51
  • They probably stop working because the driver hasn't installed yet. Can't you navigate the install program with the keyboard? – Steampunkery Apr 17 '16 at 16:53
  • 1
    Try with the different combinations of IOMMU (AMD-Vi) and USB 3.0 option settings in the UEFI (i.e. on/on, on/off, off/on, off/off). – Tom Yan Apr 17 '16 at 17:42
  • 1
    Read 2-1 and 2-6 of the manual. Press DEL to get into UEFI settings and you can found the options R_USB3.0 Controller and IOMMU controller under Peripherals. – Tom Yan Apr 17 '16 at 18:14
1

OK! As per the comments above, you burn the ISO onto the USB. I have had trouble with that in the past and I find that using dd is easier and more reliable. Look at this wiki post to see how to do it properly:

https://wiki.archlinux.org/index.php/USB_flash_installation_media

I know it's for arch Linux, but it definitely works. I have personally installed 10+ ISOs with this method. If you are making the USB on a windows computer, I find that it is easier to ask a friend to their Mac or go to a library if they have Macs there. If you know anybody who also uses linux then you can ask them instead.

  • 1
    Thanks for the answer mate but I have burnt it on a DVD and it is not working. I am not sure if Linux Kali has a USB burnable version – Dan Apr 17 '16 at 17:11
  • Never mind I found a USB boot version for it and instruction on how to do it. I will get back to you once I have tried it on a USB boot – Dan Apr 17 '16 at 17:12
  • have you tried UNetBootIn? – Steampunkery Apr 17 '16 at 17:13
  • No. I shall have a look and give it a try – Dan Apr 17 '16 at 17:14
  • Okay so a made a usb which was bootable and the same errors occur – Dan Apr 17 '16 at 18:07
1

I tried a web search for linux your motherboard name linux MotherBoard - Gigabyte 990FXA-UD3 and the first link was here http://ubuntuforums.org/showthread.php?t=2143433

Originally Posted by quattro_cs View Post

In the BIOS, set IOMMU to "Enabled". That fixed both USB and networking for me.

And further down, it suggests adding the boot option iommu=soft if further problems persist.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.