Before I left for my trip I made a backup of all my important data to an Amazon S3 bucket. I also have a Citrix remote desktop to my disposal. Today I installed the citrix client and logged in to my remote desktop. There I installed the free version of S3 browser and downloaded my backed up data. All data seems to be corrupted. Word says the documents are broken, Adobe Acrobat says there is something wrong with encoding...

How can I successfully work with my documents?

  • unknown problem or not enough information? – markus Feb 11 '10 at 9:19

It looks like that you have enabled compression and encryption in S3 Backup. So, all files you're upload, are stored in proprietary format and thereby can not be accessed through another S3 Clients.

Try to disable compression and encryption, upload some file, and you will be able to download it with any S3 Client.


It seems it was a problem with S3 browser or much rather the incompatibility of two different S3 clients. I made the backup with S3 Backup and downloaded the files with S3 Browser which caused the inconistency in encoding. When I tried using S3 Backup to download the files, everything worked fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.