0

I've setup a simple rule on one of our mailboxes which replies to every email it receives using the "have server reply using x" rule.

This is just to send a confirmation of receipt email to anyone who sends something in.

The rule also ignores our internal domains (using "except with x in the senders address) and I can see it working fine until it actually hit's the Exchange back-end. If I review the Message Tracking Log I can see that any "AutoReplies" are being dropped with the following message:

250 2.1.5 RESOLVER.MSGTYPE.AR; handled AutoReply addressed to external recipient

The SourceContext also shows:

BlockARToExternalUser

I can't find much with regards to turning this off, can anyone shed any light?

Note that if I remove the "except with x in the senders address" it does in fact deliver the auto response to an internal mailbox without issue. This only seems to affect external email

  • 1
    You want AutoReply to respond to any e-mail internal or external? Do you have auto reply turned on for external organizations? – Sun Apr 18 '16 at 15:58
  • I'm not using the built-in Out of Office/Automatic Replies - this is via a simple rule. Unless there's something I've missed in the Exchange config which would require me to enable auto-replies to external orgs? If there is, I cannot find it. – Daniel Frear Apr 19 '16 at 15:36
  • That led me in the right direction - Auto Reply to external domains was turned off on the RemoteDomain config – Daniel Frear Apr 19 '16 at 15:43
  • 1
    If you can post your comment as an answer, that will help remove this from unanswered answers. If you could provide more steps with the Exchange version you are on, this question may help someone else in the future. I thought OOTB AutoReply is preferred since it is supposed to prevent autoreply loops where receiver has auto reply turned on and you get caught in infinite loop. – Sun Apr 19 '16 at 18:35
0

After being nudged in the right direction in the comments by LunaMezza, I stumbled across the following article explaining how to enable auto replies outside the organization:

http://www.howto-outlook.com/howto/automaticreply.htm#powershell

However, as alluded to by LunaMezza this isn't to be taken lightly - your mileage may vary.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.