0

I'm trying to get my gentoo install to boot with systemd enabled, I've been using systemd on Arch and Fedora for a few years at this point and I followed the handbook and the systemd page on the wiki, but I currently have 2 problems:

  1. When it attempts to remount root as rw it doesn't issue a -o remount and instead calls the root.mount unit which then complains that the device is already in use and that it is already mounted on /
  2. It reports dependency failed for emergency shell and won't give me a password prompt and a shell as I would have expected

I enabled the debug-shell service to get a shell at boot time, but would obviously not want to leave it on, and would prefer the emergency shell worked correctly. I've also stuck with a single / partition on ext4 currently for simplicity as I'm just playing around in a VM before I intend on installing it on my laptop to use full time.

I could find some seemingly outdated information from 2010-2013 about enabling various openrc services to make sure root remounts correctly, and the equivalent service on the systemd wiki page apparently doesn't exist anyway (remount-rootfs.service).

Any help would be much appreciated.

  • Why don't you just use the rw kernel option, then? Also the service has always been called systemd-remount-fs.service. – grawity Apr 19 '16 at 4:53
  • That's good to know, that service must listed incorrectly on the gentoo wiki then: wiki.gentoo.org/wiki/Systemd Changing to rw in the grub config, applying it in /boot and rebuilding the initrd still results in an ro root mount and the same error oddly enough. The systemd-remounte-fs.service unit says it ran successfully as well, yet it is still ro. – Justin Apr 19 '16 at 5:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.