2

I have been playing around with Storage Spaces for a while now, originally in Win 8.1 and now 10, and have found the technology to be so useful.

I have recently come into possession of 10 64GB USB 3.0 Flash Drives, and I would love to build a storage space out of them.

Unfortunately, however, I cannot add these drives to a Pool. I get that there is a good reason for this (don't know what it is personally though), but is there a way to allow a Flash Drive to be used in such a way?

The one solution I have come up with in the mean time is to spin up a Virtual Machine running Windows 10 Pro, then create 10 Virtual Disks, with the VHD files being on each drive, then creating the space in the VM, but this is a bit clunky.

7

I've just figured this after a lot of googling all I found were either:

  • People asking "Why do you want to do that?"
  • No answer

So sat down and figured it out myself.

The problem is the "Removable Disk" status of the flash drives. Windows doesn't let "Removable Disks" become part of the storage spaces pool. Thus this is all you need to solve, convert all your USB Flash drives from "Removable" to "Fixed".

Searching around how to do this I found: https://www.youtube.com/watch?v=TIJ4CQQShBw "Convert USB flash drive to a Local Disk" Basically two steps:

Step 1 Find the USB Controller type

Run a tool: usbflashinfo - GetFlashInfo.exe This will dump the FlashDrive information. In my case my 12 x 16GB USB Flash drives were all the same: Phison PS2307

Step 2 Find a Fixed Disk tool Search for your Controller type. I used the site recommended in the youtube video http://flashboot.ru/ and found an app that simply converts from "Removable" to "Fixed" (and back if you want).

Results:

  • I converted all 12 x 16GB flash drives to "Fixed"
  • Plugged all 12 x flash drives (USB2.0) into a 12 port USB 2.0 Hub (non powered but it didn't seem to matter)
  • Each drive I labeled 01USB -> 12USB matching the port they were plugged into, in-case one fails I'll be able to tell which one it is
  • Ran windows Storage Spaces, all 12 USB Flash drives were shown
  • Created a Pool of all 12 with Parity (striped) and got a total drive space of 110 GB

Testing:

  • Copied 28,400 files, 3,633 folders, 2,162,576,510 bytes or (2.01 GB) from an SSD onto this storage spaces pool
  • Very busty writes, often paused at 0 transfer then climbed back up to a reasonable rate
  • Took a total of 23mins 15sec

So it's slow and bursty writing. But I'm rather impressed with the whole set-up.

Hope this helps you and who ever tried searching for a solution here.

  • 1
    Wow, what a great first-time answer Joshua! You sir deserve all the high-fives. I have just tested this myself, and works perfectly! – topherg May 12 '16 at 10:37
  • Thanks. What sort of throughput did you get? I've just tried something else, for each USB device (in device manager) change the properties of each From: "Quick removal" to "Best performance". It appears that the files are cached and streamed to the USB sticks when the computer can, rather than the computer waiting for each write to complete. Copied a single 1 GB file to the storage spaces drive in a few seconds. Though could see the USB Flash drives working away for minutes as the actual data was flushed to it. So have to be careful about allowing the cache flush before removal. – Joshua May 12 '16 at 21:11
  • as you said, it was INCREDIBLY spiky, but I managed to get about 200MB/s transfer at one point, but then nothing for about 3 mins (my USB hub was whining a lot too). I'm going to experiment with device failure shortly, seeing what happens when I just kill a stick or 2. – topherg May 13 '16 at 9:21
2

In Windows 10 x64:

  1. go to the Device Manager
  2. find the external drive under Disk Drives
  3. right-click the drive and go to Properties
  4. Go to Policies
  5. select Better Performance
  6. select Enable write-caching on the device
  7. select Turn off Windows write-cache buffer flushing on the device

My external added to my Storage Space without issue as soon as those options were selected. Prior to doing that it kept saying Cannot add the drive.

-1

It seems like Storage Space is ignoring any <4GiB disks, no matter if it is USB, SATA, VHD, VHDX, etc.

Any disk of less than 4GiB is not shown on the list, so can not select it.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.