1

Web searches show that F2 is the key to enter BIOS on Acer Aspire One and it was working fine when my system had windows 8. When I upgraded to Windows 10 recently, I see that F2 is not working. I tried power-off and power-on N times with F2 pressed, without success. It was working about 2 years ago, when I had Windows 8.
After update to Windows 10, login screen appears within about 4-8 seconds of power-on.
More-over, the first image on power-on is "Acer logo with windows circle of moving dots", which seems to indicate that windows 10 is already in control, which is probably why F2 (or ALT F10) will not enter BIOS.

Is there any way (control panel setting or freeware tool) which, when executed from window 10, can restore access to UEFI BIOS ?

  • 1
    You still have access to it – via Settings → Recovery. – grawity Apr 21 '16 at 8:47
  • @grawity , thanks for the nice pointer. The "Settings Recovery" text says "We can change boot order, change firmware settings, etc", but the button says "Restart now", which seems risky. I assume it will not automatically enter BIOS & windows will not show a boot order to save to firmware. I assume clicking the button is something like "HiberbootEnabled=0" and we still have to manually use F2; If that is the behaviour, I feel the text is misleading; It should state something like "Disable FastBoot & Reboot now. You can then enter BIOS, change firmware settings or change boot order" – Prem Apr 21 '16 at 9:53
  • Risky? What do you risk by clicking the "Restart" button? System destruction? – grawity Apr 21 '16 at 13:05
  • @grawity , maybe I am paranoid (hearing about some Linux Distro overwriting the partition table without asking the user, for example, and Windows 10 hijacking the BIOS Entry Point without informing me), but the "Advanced Startup" text says "... Change firmware settings ... or Restore Windows from a system image. This will restart your PC". On clicking the button, I would expect a window with firmware settings to change, not a reboot. What happens on reboot? Restore to the factory Default OS from the Recovery Partition ? Risky ! It might be better like "Disable FastBoot and reboot now". – Prem Apr 21 '16 at 15:23
  • In this context, restart = reboot. Sure, there could be a bug in the software, a virus, or whatever that will cause something catastrophic to happen, but at that level of paranoia you'll just be staring at your computer without touching it for fear that clicking the mouse button on the desktop will cause your system to self-destruct. – Rod Smith Apr 21 '16 at 16:04
5

You need to disable fastboot in Windows 10. You are not cold booting at the moment. If you cold boot, you will be able to use F2 as usual.

Use

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Power

HiberbootEnabled DWORD

0 = Turn off fast startup
1 = Turn on fast startup

and then boot again to access the BIOS.

  • Oh great !! It works fine now !! I did wonder how reboot was so fast, whether windows was still in control during reboots, & whether some setting controlled this behaviour. Disabling this made BIOS Entry F2 work, but reboot was too slow. Maybe I should enable this and toggle only when required. – Prem Apr 21 '16 at 9:40
  • 1
    Or just use Advanced Startup and leave it enabled always? – Ramhound Apr 21 '16 at 12:30
  • @Ramhound , yes, that is a good alternative. [[ Being paranoid, I have not yet clicked that "Restart Now" button, but I assume it will temporarily set "HiberbootEnabled=0" and reboot, and we have to manually use F2. "Advanced Statup" text is a little "misleading", in the sense that it will not show the boot order or firmware settings, for us to change and save; It will also not enter BIOS automatically on reboot. It will only "Disable FastBoot for next reboot", to allow usage of F2 to enter BIOS ]] – Prem Apr 21 '16 at 13:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.