0

Outlook 2010 is deleting my old emails. I found this question but the answer there says to check AutoArchive settings. My settings look fine, and they're grayed out anyway:

enter image description here

So is there another reason Outlook might be deleting my old emails? Scripts or macros maybe?

Thanks.

  • 1
    What are your rules looking like? Perhaps there's an auto delete rule somewhere. – adampski Apr 21 '16 at 14:07
  • 1
    Are you on a corporate network? Is your Outlook connected to an exchange server? – CharlieRB Apr 21 '16 at 14:12
  • If the options are greyed out, then its probably because (as CharlieRB suggests) you are on a corporate network and your company's admin has applied policies to control your archive settings for you. IF this is the case (you are on a work, domain-based network), you'll have to check with them. Aside from that, we can't tell you what scripts and macros you have chosen to implement unfortunately. So if you suspect scripting, what have your investigations found so far? Do you actually have scripts/macros programmed into your Outlook? – Ƭᴇcʜιᴇ007 Apr 21 '16 at 14:26
  • Yes, it's on a corporate network. But the options there don't look like they're set up for automatic deletion. – Devsman Apr 21 '16 at 14:30
  • I don't have any rules that would control this. Just a few that move automatically-generated emails to a particular folder. – Devsman Apr 21 '16 at 14:32
1

If you're in a corporate environment, it will be a Group Policy that is set by the Exchange Email Administrator.

  • Right click on youremail@yourcompany.xyz and select Folder Permissions

Folder Permissions

  • Then click on Add or Remove Retention Policies

You might get sent to Outlook for Web where you can set policies.. or nothing appears which means this is disabled by your administrator and is uneditable.

If the Folder Policy is editable, then it might give you the details of the Archive policy. It sounds like your e-mails are set to be deleted after x number of days. You can verify by seeing what is your oldest e-mail in your Sent Items.

Add or Remove Retention Policies

First check why there is a deletion policy and not retention. If deletion policy is there to save disk space (bad policy), then you could try setting up your own AutoArchive to pre-empty the policy and save your e-mail to a local PST to archives emails before they are deleted.

If Group Policy affects even your local PST, then you'll have to figure out a different way to save your old e-mails.

  • "Sorry! Access is denied!" Dang. I was trying to exercise CYA methodology, but I guess they don't want me C'ing my A. Thanks for the help. – Devsman Apr 21 '16 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.