6

I just downloaded OpenOffice 2.4.1 for Mac OS X and now every time I open it an xterm terminal window opens up with a Bash prompt. Is this normal behavior? Can this be turned off?

1
  • That is how you're supposed to use Mac OSX, isn't it? It is Unix, after all. Feb 8, 2010 at 18:59

5 Answers 5

5

OpenOffice 2.x for MacOS is an X11 application. It automatically starts X11.app, which opens the bash shell.

OpenOffice 3.0 for MacOS will render using the Mac's native display system (Quartz), so it won't start X11.app any more. Also the NeoOffice fork of OpenOffice 2.x does not use X11.

I guess window system technologies are relevant to stackoverflow.

1
  • Trying out the beta of Aqua and it is a better experience than 2.4.1. The functionality is very limited. Where is my pivot table! Sep 13, 2008 at 17:49
2

For now NeoOffice is a nicer fork of OpenOffice for the Mac.

1

You can now (as of January 26th, 2009) download OpenOffice.org 3.0.1 for Mac PowerPC - announcement here. This is an Aqua version which no longer requires the X server.

0

I'm not a Mac user, but at a guess, OOo uses X11, which by default opens an xterm? So check Apple's X11 options? Just guessing here.

1
  • Yes it uses X11 and it is very annoying. I was hoping there was a way to hide the terminal. Sep 13, 2008 at 17:21
0

I had exactly the same issue when I installed OpenOffice on Mac. The X11 integration with OSX requires that the X11 process is running if you want to use OpenOffice, X11 forwarding etc. As a work around you can make X11 start at boot (you will see the X11 icon in your dock).

The solution I ended up using for OpenOffice (on my Intel Mac) is the beta Aqua port of OpenOffice. On my older PowerPC Mac I use NeoOffice.

1
  • 2.4.1 is crap and I am moving to try the beta of Aqua. Sep 13, 2008 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.