-1

I am running CentOS 6.6, and occasionally when I spawn a new xterm window, I don't want the xterm instance to source .bashrc. Is there a way to do this?

  • What determines whether you want .bashrc to run or not? Is it only .bashrc that you want to inhibit, or /etc/bash.bashrc also? Check the --bashrc start-up option. – AFH Apr 22 '16 at 11:41
0

Your .bashrc is not read by xterm; it is read by the bash that xterm runs if you don't supply a command with -e. You can tell Bash not to read /etc/bash.bashrc and ~/.bashrc by giving it the --norc option:

xterm -e bash --norc

You may, of course, want to source /etc/bash.bashrc but not ~/.bashrc; I suggest you simply do that from within your new shell:

. /etc/bash.bashrc

but you may instead tell Bash to use that as your one and only initialization file:

xterm -e bash --rcfile /etc/bash.bashrc

Full details of those Bash options are of course in the man page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.