2

A friend has a laptop with brand new Core i7, 16 GB RAM, 1 TB SSD and 2 TB HDD.

He told me that he installed Windows 10, which was running fine, but discovered that it was 32-bit & "tried a few things" to install 64-bit. None of these "things" involved opening up the laptop, but that's about as much sense as I can get out of him.

I have his permission to delete everything, just get Windows 10 64-bit installed.

When booting UEFI, the laptop doesn't recognize an USB stick or USB DVD (he replaced the internal optical drive with the HDD). So, I am booting in legacy mode.

I can do anything – except open the laptop. My resources are Linux on USB drive and Windows 10 64-bit ISO, which I have also put onto a USB drive.  I made sure that both drives are MBR, rather than GPT (not that it matters, as he has max 2TB).

When trying to install, it blue screens with seemingly differing error messages each time, one being an exception in ntfs.sys, and one saying:

Windows cannot install required files.

Rather than chase after the errors, can someone tell me how to install, given that I can format/delete anything.

  • 1
    @Ramhound: As worded, your first comment isn't the nicest. Can you try to be a bit more gentle? – bwDraco Apr 22 '16 at 15:49
  • I am confufuesd (my fault entirely). "How do you know that "the current installation was NOT installed with legacy mode enabled"? Can you explain and help me, please? Also "How you boot to a EFI enable disk, on hardware that supports EFI, is well documented" - if I boot into UEFI, then I cannot see the USB drive with the Windowos install - am I missing something? Can you help? Thanks. – Mawg says reinstate Monica Apr 22 '16 at 17:29
  • Thanks for the clarification. I have no idea what o/s it came with. I suspect that it came with FreeDos & my friend tried to install Windows - from where, I know not. Rather than look at the past, can we look at the future & figure out how to install W 10 64-bit? – Mawg says reinstate Monica Apr 22 '16 at 18:40
7

I wil post this as an answer, in case it helps anyone else.

I tried a few other things (no point in listing them) and arrived at Error 0x80300024.

After much Googling, I found someone who said that what had worked for him was removing all drives except the one he wanted to insatll to.

That worked for me to (ymmv)

| improve this answer | |
  • 1
    Disconnecting all other drives worked for me too. A comment on this question suggest that changing the boot order might be enough though, without physically disconnecting drives. – kapex Feb 13 '17 at 14:50
  • 1
    Can confirm, This also worked for me, thank you. – Anthony Cregan May 13 '17 at 18:48
  • 1
    This worked for me. I just disabled them in bios though. Anyway thank you! – CornSmith May 12 '19 at 1:40
  • 1
    Disabling in bios didnt work ,so i just took the extra drive out. – Munib Nov 26 '19 at 18:32
  • I am glad that it worked. I was just glad to get it installed, no matter how. Bad coding on Microsoft's part, though – Mawg says reinstate Monica Nov 27 '19 at 6:29
1

Disabling the HDD in BIOS works. Had the same issue with my laptop. Initially was a little apprehensive about removing the HDD physically. But, I disabled the HDD in BIOS and then installed in the SSD. While installation only the SSD will show.Worked for me.After installation and everything, re-enable the HDD. Hope this helps...

| improve this answer | |
1

I just resolved this issue on my Laptop by changing the BOOT order for hard drives. You have to select drive on top priority in BIOS setup. THIS ACTUALLY WORKED.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.