0

My product specs list shows that my notebook sports a 1080 resolution display:

http://support.hp.com/us-en/product/HP-Pavilion-15-ab200-Notebook-PC-series/8499306/model/8818875/document/c04799692/

but my operating system only shows 1366x768 as max supported one.

I have updated my graphics drivers to latest version via windows update but i still get the lower resultion. i even tried installing latest and up-to-date drivers from vendors(intel) website but did not see any change.

so what i understand now is that either my correct product specs are not listed on the above link or i have an old bios.

i checked and noticed that my bios is indeed old but i cant update it to latest version because the bios update application reports an error due to running in non-uefi mode.

i dont wanna update my bios because that will require me to re-install the OS in uefi mode. whats worse is that even after reinstalling OS in uefi mode and updating the bios, the resolution still remains stuck at 1366x768.

please share your experiences with such issues.

1

If you use you laptop with a second monitor/docking station which only supports 1366x768 and is set as the primary monitor, this will most likely cause your problem.

If not, you might try to define a custom resolution. Also you should open a ticket at HP as it sounds for me that you specs dont meet the reality.

  • agree about opening a ticket. managed to update bios as well but still getting same lower resolution. – h.i Apr 24 '16 at 10:50

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.