2

I was messing around with some partitions on a PC that has both Windows 7 and Ubuntu 15.04 installed on it. In gparted, I distractedly formatted /dev/sda1 as fat32.

Upon rebooting, I got the message "Reboot and select proper boot device or insert boot media in selected Boot device and press a key".

I went and got an Ubuntu Linux live USB, booted it up, and then checked out the hard-drive. All of my files on both the Linux partition and the Windows partition are fine and readable, but I can't boot into either of them.

Could someone please explain to me what it is that I did and if there is a way to fix it other than moving all of my files off the current drive, reinstalling Windows and Ubuntu, and then moving all of my files back.

2
  • Tell me about it, man. I got really upset when my openSUSE partition got fubared. I noticed you haven't got an accepted answer yet so are there anymore details you might be able to add to get it answered? Apr 23, 2016 at 22:24
  • Please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration, which is required to base an answer on more than guesswork.
    – Rod Smith
    May 4, 2016 at 13:16

1 Answer 1

1

Most likely while adding and removing partitions you removed the 'bootable' flag in the partition table for the first partition. Standard MBR code will stop booting and display the message you mention if it can't find any partition that has a 'bootable' flag set.

3
  • How can I reflag it? Apr 23, 2016 at 22:16
  • Follow the gparted documentation on managing partition flags: gparted.org/…
    – Vojtech
    Apr 23, 2016 at 22:21
  • This answer might or might not be correct; it depends on what had been on /dev/sda1 and how the computer had been booting (in BIOS/CSM/legacy mode, in EFI/UEFI mode, or in a mixture of the two). The information provided by the Boot Info Script, as requested in my comment, will clarify the situation and permit a definitive answer.
    – Rod Smith
    May 4, 2016 at 13:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .