4

Host OS version: OSX El Capitan 10.11.4 (15E65)

Virtualbox version: 5.0.18r106667

Vagrant version: 1.8.1

Guest: Ubuntu-16.04

My vagrantfile looks like

   1 Vagrant.configure('2') do |config|
   2   config.vm.box = "ubuntu/xenial64"
   3   config.vm.box_url = "ubuntu/xenial64"
   4
   5   config.vm.define "tryxenial", primary: true do |machine|
   6
   7     machine.vm.provider :virtualbox do |provider, override|
   8       provider.name = "tryxenial"
   9     end
  10   end
  11 end

When I run vagrant up, it results in the following error:

Bringing machine 'tryxenial' up with 'virtualbox' provider...
==> tryxenial: Importing base box 'ubuntu/xenial64'...
==> tryxenial: Matching MAC address for NAT networking...
==> tryxenial: Checking if box 'ubuntu/xenial64' is up to date...
==> tryxenial: Setting the name of the VM: tryxenial
==> tryxenial: Clearing any previously set network interfaces...
==> tryxenial: Preparing network interfaces based on configuration...
    tryxenial: Adapter 1: nat
==> tryxenial: Forwarding ports...
    tryxenial: 22 (guest) => 2222 (host) (adapter 1)
==> tryxenial: Running 'pre-boot' VM customizations...
==> tryxenial: Booting VM...
==> tryxenial: Waiting for machine to boot. This may take a few minutes...
    tryxenial: SSH address: 127.0.0.1:2222
    tryxenial: SSH username: ubuntu
    tryxenial: SSH auth method: password
The guest machine entered an invalid state while waiting for it
to boot. Valid states are 'starting, running'. The machine is in the
'gurumeditation' state. Please verify everything is configured
properly and try again.

If the provider you're using has a GUI that comes with it,
it is often helpful to open that and watch the machine, since the
GUI often has more helpful error messages than Vagrant can retrieve.
For example, if you're using VirtualBox, run `vagrant up` while the
VirtualBox GUI is open.

The primary issue for this error is that the provider you're using
is not properly configured. This is very rarely a Vagrant issue.

When I open the virtualbox GUI and click on Machine > Show Log, the log ends with

00:00:02.804262 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
00:00:02.804277 emR3Debug: rc=VERR_MORE_DATA
00:00:03.813006 Changing the VM state from 'RUNNING' to 'GURU_MEDITATION'
00:00:03.813034 Console: Machine state changed to 'GuruMeditation'

Does this indicate that I should tell virtualbox to allocate more memory to the vm, or that virtualbox is trying to allocate memory but not able to, or something else?

It seems to being raised from https://www.virtualbox.org/svn/vbox/trunk/src/VBox/Main/src-client/GuestCtrlPrivate.cpp

migrated from serverfault.com Apr 23 '16 at 23:34

This question came from our site for system and network administrators.

4

Upgrading from VirtualBox 5.0.18 to 5.0.20 (released on 4/28 ... 5 days after this question was posted) solved this exact problem for me. So no need to downgrade to 5.0.16 any longer.

2

I was running into this same issue with VB version 5.0.18. It seems the ubuntu/xenial64 box was built with virtualbox 5.0.16. Uninstalling 5.0.18 and installing 5.0.16 worked for me.

  • 2
    It seems (but I've not been able to confirm) that this box was also built without guest additions, so synced folders does not work on it. – Andrew M. Farrell Apr 25 '16 at 23:30
1

One way to solve this is to install the OSX test build of virtualbox. https://www.virtualbox.org/wiki/Testbuilds. It seems to be a bug specific to the current release version that I run.

  • It no longer seems like it would be a good idea to install a test build of VirtualBox if a new version of VirtualBox that solves the problem is available, as agileafro says. – karel May 2 '16 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.