1

Help! I just started having an issue where I can't mount any DMG files on my Macbook Pro! I recently upgraded to El Capitain and everything seemed to be fine until today. Here's what I noticed, which may or may not have had an impact.

I plugged in my iPad using a cheap third party lightning cable from Target which barely works in the wall and I got a prompt saying "USB devices disabled. Unplug device consuming too much power to enable." I unplugged the iPad and the cheap cable then went to mount the Android Studio DMG file I just downloaded. I got the "no mountable filesystems" error. I tried to download the dmg again but the problem persisted. I then tried to download a few other DMG files as I suspected there was actually nothing wrong with the Android Studio DMG. I tried the SourceTree dmg as well as Charles Proxy's dmg and they all give the same error. I tried to reboot and I still have the problem. I suspect I may have damaged something with this cheap USB cable but I'm not sure. Is there a way to identify/fix the problem here? It just started happening today immediately after I tried the cheap cable.

I'm also seeing this error when I open the Mac App store and click the updates tab:

The operation couldn’t be completed. (NSURLErrorDomain error -1012.)

More info, I've tried opening all of the DMGs on another Mac and they all work so I know they aren't corrupted. I've also tried mounting from the command line as suggested here but I get errors:

SFO1212474815A:Downloads 212474815$ sudo hdiutil attach -noverify -nomount /Users/212474815/Downloads/Skype_7.26.328.dmg
/dev/disk2              GUID_partition_scheme
/dev/disk2s1            Apple_HFS
SFO1212474815A:Downloads 212474815$ diskutil verifyDisk /dev/disk2
Unable to verify this whole disk: The target disk is too small for this operation (-69771)
SFO1212474815A:Downloads 212474815$ sudo diskutil mountDisk /dev/disk2
One or more volume(s) failed to mount

I've tried hdiutil attach with verbose output and I get this:

SFO1212474815A:Downloads 212474815$ sudo hdiutil attach -verbose /Users/212474815/Downloads/Skype_7.26.328.dmg
Initializing…
DIBackingStoreInstantiatorProbe: interface  0, score      100, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score    -1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score      100, CCarbonBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  6, score    -1000, CVectoredBackingStore
DIBackingStoreInstantiatorProbe: interface  0, score      100, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score    -1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score      100, CCarbonBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  6, score    -1000, CVectoredBackingStore
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CMacBinaryEncoding
DIFileEncodingInstantiatorProbe: interface  1, score    -1000, CAppleSingleEncoding
DIFileEncodingInstantiatorProbe: interface  2, score    -1000, CEncryptedEncoding
DIFileEncodingInstantiatorProbe: interface  0, score      900, CUDIFEncoding
DIFileEncodingNewWithBackingStore: CUDIFEncoding
DIFileEncodingNewWithBackingStore: instantiator returned 0
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CSegmentedNDIFEncoding
DIFileEncodingInstantiatorProbe: interface  1, score    -1000, CSegmentedUDIFEncoding
DIFileEncodingInstantiatorProbe: interface  2, score    -1000, CSegmentedUDIFRawEncoding
DIDiskImageInstantiatorProbe: interface  0, score     1000, CUDIFDiskImage
DIDiskImageInstantiatorProbe: interface  1, score        0, CSparseBundleDiskImage
DIDiskImageInstantiatorProbe: interface  2, score        0, CSparseDiskImage
CRawDiskImage: data fork length 0x0000000002B432FE (45363966) not a multiple of 512.
DIDiskImageInstantiatorProbe: interface  3, score     -100, CRawDiskImage
DIDiskImageInstantiatorProbe: interface  4, score        0, CDARTDiskImage
DIDiskImageInstantiatorProbe: interface  5, score        0, CDiskCopy42DiskImage
DIDiskImageInstantiatorProbe: interface  6, score    -1000, CNDIFDiskImage
DIDiskImageInstantiatorProbe: interface  8, score     -100, CShadowedDiskImage
DIDiskImageInstantiatorProbe: interface  9, score    -1000, CCFPlugInDiskImage
DIDiskImageInstantiatorProbe: interface 10, score     -100, CWrappedDiskImage
DIDiskImageNewWithBackingStore: CUDIFDiskImage
DIDiskImageNewWithBackingStore: instantiator returned 0
Verifying…
Verification completed…
Error 0 (Undefined error: 0).
expected   CRC32 $E26D0E99
Attaching…
DI_kextWaitQuiet: about to call IOServiceWaitQuiet...
DI_kextWaitQuiet: IOServiceWaitQuiet took 0.000002 seconds
2016-04-24 06:56:52.829 diskimages-helper[5881:208283] DIHelperHDID serveImage: attaching drive
{
    autodiskmount = 1;
    "hdiagent-drive-identifier" = "442EA6B6-1035-4329-96D5-058628BB0C57";
    "unmount-timeout" = 0;
}
2016-04-24 06:56:52.830 diskimages-helper[5881:208283] DIHelperHDID serveImage: connecting to myDrive 0x4A0B
2016-04-24 06:56:52.830 diskimages-helper[5881:208283] DIHelperHDID serveImage: register _readBuffer 0x111bc0000
2016-04-24 06:56:52.831 diskimages-helper[5881:208283] DIHelperHDID serveImage: activating drive port 18699
2016-04-24 06:56:52.831 diskimages-helper[5881:208283] DIHelperHDID serveImage: set cache enabled=TRUE returned SUCCESS.
2016-04-24 06:56:52.831 diskimages-helper[5881:208283] DIHelperHDID serveImage: set on IO thread=TRUE returned SUCCESS.
2016-04-24 06:56:52.831 diskimages-helper[5881:208283] -processKernelRequest: will sleep received
Mounting…
2016-04-24 06:56:53.048 diskimages-helper[5881:208275] -remountReturningDictionary: detaching because no mountable filesystems.
Attaching…
Error 112 (no mountable file systems).
Finishing…
DIHLDiskImageAttach() returned 112
2016-04-24 06:56:54.089 diskimages-helper[5881:208271] *** -[NSMachPort handlePortMessage:]: dropping incoming DO message because the connection is invalid
hdiutil: attach failed - no mountable file systems

I also gt a similar CRC error when logging in with a brand new user account. I wonder if there's something in El Capitain that's causing this? I no longer think it's related to the cheap cable as I've plugged the iPad in again with a proper cable and iTunes mounts the iPad.

4
  • More information would help — if you download a fresh, known-good DMG (e.g. adium.im ), then run, e.g., hdiutil attach -verbose /the/path/to/Adium_1.5.10.2.dmg, does it mount? What's the output? The other helpful diagnostic would be if a fresh new user account can mount some DMGs — maybe it's something with your account. Apr 24, 2016 at 12:53
  • Thanks for your reply. I've updated my question with your suggestions. I'm certain that the DMG files are not corrupt as they open on another Mac.
    – Cliff
    Apr 24, 2016 at 13:59
  • Oh and I haven't tried mounting from another user account yet. I'll do that in a few. Thanks again for the suggestions.
    – Cliff
    Apr 24, 2016 at 14:00
  • @Cliff Have you found solution? I have similar issue. Only rebooting helps me.
    – mixel
    Sep 13, 2016 at 8:40

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.