1

I have open vpn server running on a raspberrypi with debian jessie. And it works fine with the open vpn client for windows. But the same ovpn file configuration that works for windows 7 does not seem to work for Android or IOS. It connects but then it does not route any traffic. It can't resolve any domain. And I can't ping google's ip (for example).

My server config looks like this:

port 1194
proto udp
dev tun

ca      /etc/openvpn/easy-rsa/keys/ca.crt    # generated keys
cert    /etc/openvpn/easy-rsa/keys/server.crt
key     /etc/openvpn/easy-rsa/keys/server.key  # keep secret
dh      /etc/openvpn/easy-rsa/keys/dh2048.pem

server 10.9.8.0 255.255.255.0  # internal tun0 connection IP
ifconfig-pool-persist ipp.txt

keepalive 10 120

#comp-lzo         # Compression - must be turned on at both end
persist-key
persist-tun


mssfix 1450
tun-mtu 1500
tun-mtu-extra 32

push "redirect-gateway"
push "dhcp-option DNS 10.9.8.1"
push "dhcp-option WINS 10.9.8.1"

status log/openvpn-status.log

verb 5  # verbose mode
client-to-client

I also tried to push google's dns (that didn't work for any of them):

push "dhcp-option DNS 8.8.8.8"
push "dhcp-option WINS 8.8.8.8"

And my client config has inline certs and looks like this:

client
dev tun
port 1194
proto udp

remote somevpnserver.com 1194 
nobind

#comp-lzo
persist-key
persist-tun

mssfix 1450
tun-mtu 1500
tun-mtu-extra 32

push "dhcp-option DNS 8.8.8.8"

verb 5

<ca>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</ca>

<cert>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</cert>

<key>
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
</key>
1

I've managed to get it working with part of what I found here.

push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 8.8.8.8"
user nobody
group nogroup

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.