I am actually backing my whole 2tb disk using Clonezilla disk-to-image option.

I don't use any encryption or anything that I know that could slow down the process, and yet, Clonezilla tells me that there is 72 hours remaining at a speed of 400MB/min.

When I started it, Clonezilla told me that it would take 8 hours at 3gb/min but that speed just kept decreasing over time. Now one hour after the start of the copy, I am at 400mb/min and it keep decreasing. Is it normal ?

I am using Clonezilla on a bootable USB Key and the external hard drive receiving the copy image is new and healthy (using usb3 too). The only bad point I can think of is that the disk I am copying is usually a bit slow on my Windows (something is wrong with it, I don't know what) but still it shouldn't be THAT slow (and doesn't explain why it started at 3gb/min).

Is there anything I can do to speed up the process? Is it safe to reboot my computer during the copy and try again? Should I even bother trying again?


Ok, 10 minutes after my question it is now at 84 hours. I just want to know if it is safe to shut it down because I am not going to wait the whole week for that.

  • 2
    Compression makes a big difference pgzip vs pbzip. pbzip can be way faster. You need to use a type starting with p for multi-core compression. The compressible of the data plays a big factor in speed.
    – cybernard
    Apr 24, 2016 at 15:10
  • 2
    bad/weak sectors also significantly slow the drive down when it needs to ECC a lot of sectors.
    – cybernard
    Apr 24, 2016 at 15:41
  • 1
    those are estimated times and can change at any point during the clone process, I agree with cybernard, the drive you are cloning from may have bad sectors or other performance issues.
    – Moab
    Apr 24, 2016 at 16:19
  • 1
    You can press CTRL + C to cancel the current copy process. Just keep doing that until the cloning stops. After that you can just shut down normally.
    – chue x
    Apr 24, 2016 at 16:53
  • I have exactly the same behavior, have you found a solution for your issue so could actually clone the disk?
    – Thomas
    Aug 22, 2016 at 20:42

5 Answers 5


In principle, if you are talking about rotating rust, its speed always decreases towards the end of the media in modern HDDs. This is because of how they are constructed and how the data is laid out. The linear speed on a healthy drive should decrease twofold towards the end.

  1. Data is written in (almost) constant areal density (with constant number of bits per track unit length, and all tracks have same width).
  2. Consequence: inner tracks (rings of bits) on the disk surface fit less bits than outer tracks, because outer tracks are longer.
  3. The disk rotation speed is constant. The complete track is read or written in a constant time; for 7200 RPM disks the whole track is processed in 1/120 second — it doesn't matter inner or outer.
  4. Combine those facts: inner track has fewer bits to read in the same time as outer track. So, inner track is slower in bits per time to read or write than outer track. When the head moves towards the rotation axis, the disk linear speed becomes slower ans slower.
  5. Other way to think of this is: bits spread on the surface uniformly, but the rotating surface has less linear speed relative to the head when the head is closer to the axis, so less bits per second fly near the head when it is closer to the axis.
  6. The difference is proportional to the radius of the track, and the ratio of radii between outer and inner tracks is around 2, so outer tracks of disk are able to perform twice as fast in comparison with inner tracks.
  7. The disk begins from outer track (like vinyl disc, albeit HDDs have concentric rings and not a continuous spiral). LBA 0 lies on the most outer track, last LBA is on the most inner track.

So, when you scan the HDD sector by sector (it doesn't matter read or write), it begins from LBA 0, which lives on fast outer track, displaying the fastest speed the drive can deliver. Then, as LBA increases, the head seeks closer and closer to the axis, moving to slower and slower tracks. The speed which disk can deliver there gradually decreases towards the end.

This is not the sign of malfunction or imminent death of the disk. This is normal, expected behavior. If you don't like it, use SSDs.


i had the same issue , i was using Clonezilla from Parted.Magic 2017-06-12 to clone SSD->SSD sata3 , the speed was starting at 12GB/min but after 1min was droping to 5 and later to 1, after i boot it in 64bit mode (at parted magic select Default 64 instead of 32) the issue was gone, i got 9GB/min average at cloning 60GB.

  • One possible reason is that the SSD throttles because it overheats. I found significant speed improvements under this use scenario when opening the case of an external SSD.
    – user52366
    Sep 29, 2021 at 18:05

I experienced this speed degradation many times on different setups. It usually happen when recovering data from failing(but somehow still working) HDD.

This solution helped me in one of such cases:

  • while still in Clonezilla, notice what is your source and target partitions and disks (for example source:/dev/sda1 target:/dev/sdb1) It is very important, otherwise you will rewrite your data.
  • cancel Clonezilla cloning process (Ctrl+C) and enter command line prompt
  • $sudo ddrescue -n --force /dev/{your source partition} /dev/{your target partition} myrecoverylog.txt

-n options postpone recovery of most hard to read blocks until the end of the process, so you may even skip recovery of them with Ctrl+C. Here, on ddrescue page are details: https://www.gnu.org/software/ddrescue/manual/ddrescue_manual.html


I had this problem exactly as the original poster described.

I managed to fix it by using an external USB harddrive (this was the same destination device for storing the backup as before) and reformatting it with a block size of 4096 bytes.

My data transfer rate then stayed at 2.93 GB/min and the backup went smoothly. Before, the speed was 173MB/min and the block size was 1 MB.

I'm not an expert, so just sharing what worked for me.


I had this problem using Parted Magic (pmagic_2022_03_28). Then I downloaded "clonezilla-live-3.0.1-8-amd64.iso" and tried that and everything went smooth and fast. Average rate was at 23GB/min :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .