A couple of months ago, my Win7 PC unexpectedly became unable to boot normally. I'm able to boot into the various Safe Modes, but everything else fails (including what is sometimes called a "clean boot," in which msconfig.exe is used to disable non-essential drivers, services, and programs).

The last time I used my PC normally, I played Skyrim for a few hours and then shut down normally. I use my PC for gaming only, and hadn't really installed any new software in 4 or 5 months.

When I attempt to boot, I get the "Starting Windows" screen with the pulsing logo, and then after a couple of seconds the screen goes black and the mobo BIOS screen reappears -- the computer has just rebooted. Just before the screen goes dark, there is a quiet but distinct "click" sound from inside the tower. It is not an unusual sound -- there are several large fans and 4 or 5 HDDs in there, and the machine has always made a lot of interesting noises while booting -- but its proximity to the failure is suggestive.

I've been fixing my own Win machines for a long time, but after 2 months of experimenting every weekend, I'm out of ideas. I've got a CBS.log file that purports to describe the problems that couldn't be fixed by the System File Checker, but nothing inside looks serious. And while the log suggests that repair completed successfully, stdout says otherwise:

C:\Windows\system32>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.
Windows Resource Protection found corrupt files but was unable to fix some of them.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example
C:\Windows\Logs\CBS\CBS.log

I've read that sfc needs to be run several times to accomplish its work. I've run it literally dozens of times, and every time it says it was unable to fix some of the problems it found. I've examined a lot of these logs, and it's not actually clear that anything is being accomplished -- the number of work items appears to be roughly constant over time (I have not counted carefully). At this point, the only reason I run sfc at all is that it's the only tool that finds problems, and it's the most verbose of the system recovery tools available without booting normally.

I have already run chkdsk, but it found no errors.

I have attempted to repair my boot sector and MBR, based on a cryptic, once-only error code seen during System Recovery (I don't recall the error code). It did not fix the problem, but for several hours I was forced to boot from the Win7 install disc, until I successfully repaired the damage I had done (I think). I think this suggests that the boot sector & MBR are fine.

I have uninstalled my graphics drivers (nVidia).

Automatic Windows Update is disabled. I personally inspect every available update before downloading and installing it. I stay on top of it, and generally only refuse updates that are about Win8 readiness.

I tried to do a "repair installation" of Win7 from the DVD, but it refuses to do that from Safe Mode (which really makes me wonder WTF the point is -- medicine that only healthy people can take?).

At this point, I really feel like I need someone to hold my hand; I've done an extensive amount of research and experimentation with the various recovery strategies that are mentioned online, and none of them has made a difference.

I'm attempting to boot Win7 Home Premium (64-bit) SP1 from a 60GB SSD (7.5 GB free).

Any help is appreciated.

-- UPDATE --

I tested booting the PC with all drives disconnected except the primary, and it still failed.

I booted the machine using an Ubuntu Live USB, and used Disk Utility to inspect the boot disk. It reports the disk is healthy, and shows three partitions:

  1. 105 MB FAT "EFI System Partition"
  2. 134 MB "Microsoft Reserved Partition"
  3. 64 GB NTFS "Linux Basic Data Partition"

When I run "Check Filesystem" on each parition, both 1 & 2 are described as "clean," but 3 is described as "not clean."

More about partition 3:

  • Overall assessment: Disk is healthy
  • Power Cycles: 2819
  • Bad Sectors: None
  • All but one of the various error metrics are at 0; there are 31 "Data Address Mark Errors"

I ran the extended SMART Self-test, and none of these values changed, and the disk is still reported as "healthy."

Based on this SE thread, I ran sudo ntfsfix /dev/sda, but it failed with really interesting information:

ubuntu@ubuntu:~$ sudo ntfsfix /dev/sda
Mounting volume... NTFS signature is missing.
FAILED
Attempting to correct errors... NTFS signature is missing.
FAILED
Failed to startup volume: Invalid argument
NTFS signature is missing
Trying the alternate boot sector
Unrecoverable error
Volume is corrupt. You should run chkdsk.

I've already run chkdsk on the drive about 15 times, and each time it completes successfully with no errors.

What do I do next?

-- UPDATE --

From my Ubuntu Live USB stick, I am able to mount and explore both the EFI partition and the large main one. The Disk Utility GUI doesn't present an option to mount the other one, and I assume that a "Microsoft Reserved Partition" probably won't play well with *nix.

Days spent researching "NTFS signature" have not proved helpful.

-- UPDATE --

The "NTFS signature" issue appears to be unrelated. I was specifying the wrong device (/dev/sda instead of /dev/sda3). When I corrected the command, ntfsfix ran successfully. The boot problem is not fixed, however.

I've since removed my video cards, and now I see a BSOD where the screen used to be blank. The message is:

STOP: c000007b {Bad Image}
Exception Processing Message c000007b Parameters 19b6aa0 0 0 0
  • Edit your question and add more details plus a link to the file, also edit the title to reflect the real question. This is the right place for that type of question. – Moab Apr 25 '16 at 0:52
  • The click may be an indication of a HD failure. Are your HDs spinning disks or SSDs? I would fire up a Linux live CD to read the SMART data off the HD(s). – Nathan Adams Apr 25 '16 at 1:28
  • look inside the CBS.log which files can't be restored. – magicandre1981 Apr 25 '16 at 4:20
  • 3
    1 Have you tried cloning the drive to another disk using a free tool such as clonezilla for windows? If you can't clone could point to hardware failure. If you can clone, your chkdsk /r or sfc /scannow may be more fruitful. 2 for smart attributes you want to look at crc error or read retries. Every disk is different and it may be hard to interpret values. 3 can you review your event viewer logs at all? That may give you more details filtered on error warnings – Sun May 28 '16 at 0:58
  • 1
    Don't run ntfsfix against /dev/sda ! That's the whole disk - you'll corrupt your drive. Only run it against your NTFS partition, which sounds like is sda3. – rrauenza May 28 '16 at 1:18

When you are presented with the boot menu, there should be an option to stop the computer from automatically rebooting. Enable it and try booting normally into Windows. If done correctly, the machine will not reboot automatically and instead will display a blue screen with a STOP error code at the very top. That code is essential to correctly diagnosing this problem.

  • I wasn't able to find that setting anywhere in the UEFI menus, but I did find it in Windows Advanced System Settings > System Startup and Recovery. With automatic restart disabled, the Starting Windows screen appears for a few seconds, then goes blank and stays blank indefinitely (>20 minutes). All HDD activity stops moments after the screen goes blank. No memory.dmp file was created (I looked for it afterward in Safe Mode). – Tom May 28 '16 at 6:12
  • I removed my video cards and now I see a BSOD where the screen used to be blank. The message is STOP: c000007b {Bad Image} Exception Processing Message c000007b Parameters 19b6aa0 0 0 0 – Tom May 28 '16 at 7:13

Your problem is clearly a 'rogue' driver...

You have try most of the advice I could have give you...

Now you have to become a bit radical to solve the problem...

1. Boot in security mode (or better boot from a alternative OS)
2. make a backup folder to move/save some driver files
3. locate your c:\windows\system32\drivers folder
4. order files by date, and move a few "dates" to the backup folder

Now try to reboot... If problem persists, put back the 'saved' files
and do the same process for the next 'dates'

Hope you'll solve it...

  • No good. The most-recently modified file in `C:\Windows\System32\drivers` is dated 2015-12-04 -- two months before the problem occurred. Thanks, tho! – Tom May 28 '16 at 22:31

From what I read I am pretty confident that you should try cloning the drive to another disk (as somebody already suggested) and if this fails then SpinRite will fix it.

According to your information, when booting from the same Windows 7 SP1 CD which you used to install Windows, you get the error message that you need to use an install disc that matches the installed OS.

I take it to mean that the Windows installation was destroyed. A difference of one byte can be the difference between a Windows installation being recognized or not, so you have at least one bad sector on the hard disk.

I would suggest to backup your data and reinstall Windows from scratch. You should first re-format the disk with slow formatting, which will mark bad sectors and reinitialize the magnetic signatures of the sectors. If problems still occur, a new hard disk might be in order.

  • reinitialize the magnetic signatures of the sectors ? OP wrote: I'm attempting to boot Win7 Home Premium (64-bit) SP1 from a 60GB SSD (7.5 GB free) – Vojtěch Dohnal Jun 1 '16 at 12:32
  • @VojtěchDohnal: Right - formatting does not apply to SSD. To reinitialize an SSD see for example this article : How To Securely Erase Your SSD Without Destroying It, which should only be done in extreme cases. In the case here, a quick format should be enough. – harrymc Jun 1 '16 at 12:54
  • 1
    I've run chkdsk dozens of times while troubleshooting, finding 0 bad sectors. HDTune also reported 0 bad sectors found, and the SMART data from the drive does not suggest there have been any failures now or in the past. This seems to falsify your inference that there are any bad sectors on the disk. Presumably, the solution would be finding that "one bad byte" and re-writing it, and I assume this is precisely what sfc is for. The fact that it consistently fails not only to fix the problem but even to improve the situation suggests there is a larger problem... somewhere. – Tom Jun 2 '16 at 3:10
  • Bad data does not always imply bad sector, which might be what is happening in your case. My advice is not to look for the bad byte(s) but to move on. – harrymc Jun 2 '16 at 4:35
  • How did this end? – Vitas Jun 20 '16 at 16:47

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.