Some of our users in our organization has started to report a strange error when installing our product (product details redacted from the screenshot):

Screenshot of the danish error message

The original error message in English is "Installation directory must be on a local drive".

Changing the path to something without spaces, alternate root folders or even other physical drives on the machine changes nothing. The installer still insists that the path isn't a local path.

This installer is created with WIX, and the specific step in the process is created with the custom action WixUIValidatePath. A bug has previously been submitted, that also indicates that the error is related to restrictions on the installer (thanks to peterflynn on GitHub for pointing me in that direction).

The problem only occurs on some computers, and it appears that no one has the issue in Windows 10. I have not been able to test if it occurs in other Windows versions a part from 8.1, as that and Windows 10 are the only versions we run.

  • What is the relationship of the [wix] tag to this question?
    – CharlieRB
    Apr 25, 2016 at 16:58
  • Will edit it in once im at conputer again. See answer for details. @CharlieRB Apr 25, 2016 at 17:00
  • NP...Yes, I see the reference to Wix in the answer. This is a good question and answer, I just wanted to make sure if the tag is important to the question, there should be some mention of it in the question.
    – CharlieRB
    Apr 25, 2016 at 17:08
  • @CharlieRB: Exactly, I simply forgot that detail, so thanks for pointing it out! :) It should be clearer now. Apr 25, 2016 at 17:18

2 Answers 2


After much debugging we narrowed it down to problems with rights to temp folders with the current user. Different steps resolved the issue on different computers. Here I will be listing the fixes from the least to the most invasive approaches:

  1. Ensure that the installer is run as administrator
    This is something we already require, but some users tend to forget this. This is also the most common solution to the issue I've found when searching for a solution.
    The simplest way to ensure this, is by pressing the WinKey and type cmd to find the command prompt, and then press CTRL + SHIFT + ENTER to open the command prompt as administrator, then navigate to the msi folder (for navigation instructions, see this link) and run it from there.
  2. Manually install KB3072630
    Some of our users had, for some reason, not correctly received this particular update from MS which seemed to fix the issue! This was where most users got their problem resolved.
  3. Run the installer silently
    The bug is related to a WIX UI component, so running the the MSI silently will not activate the UI component, and therefore the bug will not be triggered either. You can do this through the commandprompt as specified in above step, but with these added parameters to the MSI:
    Thanks to Kr3m on GitHub for this approach
  4. Run the installer with UI check disabled
    The WIX UI component that bugs it all up can also be disabled. WARNING: This will also disable any sanity checks on the installation path, and might mess up the installation process! This can be done with another commandline parameter:
    Thanks to peterflynn on GitHub for this approach
  5. Disable LUA
    The only sure way to remove the issue, was to disable the LUA completely, which was the standard for some of our environments, to be able to work with legacy features. Disabling LUA completely requires manual changes to the registry, so be sure that you know what you are doing, and the consequenses of it as well. Instructions can be found here on MS' forum.

One thing we did not test, that might solve it as well, is to recreate the user on the computer, because we think it has to do with access rights to the users own temp folders. They might be recreated correctly through a recreation of the user.


try this

open cmd and perform this command

msiexec /i "c:\AnyPath\YourInstaller.msi" WIXUI_DONTVALIDATEPATH="1"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.