3

Same problem as so many people: My computer wakes itself, but I can't determine the source. Windows 10. It's happened around 3:40am, 12:21am, etc. Seems to happen every few weeks.

These are some details regarding my system configuration after the wake happens:


Configruation:

powercfg -devicequery wake_armed → NONE

powercfg -waketimers → There are no active wake timers in the system.

Power Options Advanced Settings → Sleep → Allow wake timers → Disable

(Classic) Control Panel / System and Security / Security and Maintenance / Automatic Maintenance → "Allow scheduled maintenance to wake up my computer at the scheduled time" unchecked.

All wake on "Magic Packet" or "Pattern Match" or "Link Settings" of all network adapters are set to "Disabled" in the Advanced settings of the devices in Device Manager.

ASRock Z170 Extreme 7+ motherboard (no "wake from sleep" options found in UEFI).


Diagnostic Info:

Event Viewer → Wake Source: Unknown

powercfg -lastwake → Wake History Count - 1, Wake History [0]: Wake Source Count - 0

  • What has your research effort shown using Google? Questions on SU are expected to show some research effort on your part and should be included in your question. Did you check your bios settings? – Moab Apr 25 '16 at 21:33
3

I think I finally found out how to tell what the wake source is in this scenario:

Get-ScheduledTask | where {$_.settings.waketorun}

This shows the "Reboot" task under UpdateOrchestrator which I believe might have been causing the problem.

Instructions on how to disable it are found in Step 2 of this fantastic answer: https://superuser.com/a/973029/226996

I'll report back if I'm finding the computer is still waking and I can't determine the source with this method...

0

I had this problem as well. I fixed it once but after about 4 months it started again. This time eventlog entries show Wake Source: Unknown, but I found a scheduled task shell-usoscan which had Wake up computer to run this task checkbox checked. Weirldy I don't see this task reflected in any system settings, but unchecking that checkbox helped and the pc stays sleeping when I get home from work.

0

I also had the issue of an unknown wake source, but I saw from the Windows System log that right after sleep was aborted (Power-Troubleshooter entry) the next event involved the Ethernet adapter that was connected to the LAN. Turning of the adapter power triggering stopped the issue, and then turning it back on but restricting the wake action to magic packets solved the issue. Not sure why the cmd for lastwake couldn't reveal this, but it might be helpful to others.

Windows System Logf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.