1

I have a surface pro 3, with Skype 7.22.0.109 installed on Windows 8.1. When in calls, I can hear received audio, but my microphone will only give static or nothing. I have checked in the settings and the surface's microphone is selected, and I have tried to reinstall Skype several times.

The microphone is working fine in other applications, such as Google Hangouts or the Sound recorder. I have also tried the web based version of skype and it still does not work, and I have also tried adjusting the levels of the microphone to no avail. Skype did work with the original Metro skype that came with the machine, but hasn't worked with Skype for Windows (desktop).

I do not see any optional updates specifically marked for audio in Windows update (but there are ~200 with "Update for Windows 8.1 (KB #)").

  • Have you simply tried a restart, or uninstalling and reinstalling Skype? – JCTechie May 6 '16 at 13:28
  • Yes to all three. – Batman May 6 '16 at 13:40
  • Have you tried downloading the metro version from the windows store? It may be a hassle but it might be what you have to use. Also, is your PC set to allow the MIC with applications? – JCTechie May 9 '16 at 1:09
  • The Metro version is no longer supported and just tells you to download the desktop version. And yes, it is. – Batman May 9 '16 at 3:37
  • As for the microphone, it works in everything but Skype. – Batman May 9 '16 at 20:17
1

If you can use the microphone in other applications, then you don't have a problem with the sound driver, and it might be just settings issue.

So, you need to check the followings:

First check Windows 8 privacy settings

  • Go to PC Settings
  • Then, choose Privacy
  • Now, click on Microphone

Make sure that Let apps use my microphone is On, and then make sure that Skype option is ON under Let these apps use my microphone

Now, start Skype and go to Skype Settings. Check the Microphone Settings and try it out.

  • Skype doesn't appear in that list for me. – Batman May 10 '16 at 15:03
  • @Batman check Privacy > Webcam – iSR5 May 11 '16 at 10:15
  • It doesn't appear there either. I think this is only for metro apps since the webcam works fine in Skype. – Batman May 11 '16 at 11:02
  • @Batman just to check, have you tried to use a headset microphone with skype ? if not, then try and check if the microphone is working with it or not. – iSR5 May 11 '16 at 11:05
  • I'm trying to acquire one. – Batman May 12 '16 at 15:49
0

Skype will only work now with microsoft own driver, if your pc is old then you will have a very hard time trying to get the driver, good news is that the orginal driver is on the windows disc, you will need to download that driver.

-1

It sounds like the Skype Windows app is what was working better for you. Unless there is a reason you did not like it you can get it from the Microsoft app store.

If that does not work you could try to uninstall the microphone from the Device Manager. Reboot and let the device reinstall and see if that corrects the issue. Warning: you may need to download the manufacturer's driver before the microphone will reinstall properly. You probably want to download this ahead of time, before uninstalling. Below is an example of a Device Manager with uninstall microphone showing.

Example of Device Manager with uninstall microphone showing

  • The Skype that did work is no longer supported by Microsoft. I tried uninstalling and reinstalling the drivers to no avail (with the drivers downloaded as part of the pack provided by Microsoft). – Batman May 4 '16 at 8:08
-1

It seems to me your PC is not compatible with the newest Skype, try these older versions:

6.14.0.104: https://web.archive.org/web/20140413131237/http://download.skype.com/msi/SkypeSetup_6.14.0.104.msi

6.18.0.106: https://web.archive.org/web/20141119080039/http://download.skype.com/msi/SkypeSetup_6.18.0.106.msi

6.21.0.104: https://web.archive.org/web/20141213144457/http://download.skype.com/msi/SkypeSetup_6.21.0.104.msi

(Taken from https://community.skype.com/t5/Windows-desktop-client/Older-versions-of-Skype/td-p/3951877)

Make sure after installing an older version to disable automatic updates, Tools -> Options -> Advanced -> Automatic Updates -> disable

  • Best version to use is 6.21.0.104! – JCTechie May 9 '16 at 18:43
  • No luck with the older versions. – Batman May 9 '16 at 20:15
  • Have you tried using a different mic? – JCTechie May 12 '16 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.