I have a samba share in an arch linux server, that I cannot access from OSX, but I can access it normally from any Windows machine. When I try to access it from the terminal (from OSX) with the anonymous user it returns an authentication error:

$ smbutil view -a //
smbutil: server rejected the authentication: Authentication error

When I try to access it with guest access I get:

$ smbutil view -g //
smbutil: server connection failed: Invalid argument

Here is my smb.conf:

        workgroup = WORKGROUP
        server string = Shares
        security = user
        map to guest = Bad User
        logfile = /var/log/samba/%m.log
        max log size = 50
        dns proxy = no

        path = /mnt/data
        guest ok = yes
        read only = no
        browsable = yes
        force user = nobody
        force group = nobody
        create mask = 0755
        directory mask = 0755

In Finder, choose Go -> Connect to Server, and in the server address box enter


  somedomain is the domain you log in via as if logged onto the windows machine, 
  someuser is your user id, 
  someserver is server hosting the share you're trying to access
  /path/to/data is the rest of the path to the location you want
| improve this answer | |
  • Late to the game, this solved my problem. – jsimon Feb 9 '19 at 2:39

It's a Bug in Samba affecting OSX clients. It drove me mad!


| improve this answer | |
  • 1
    Answers should contain quote and cite all relevant information from links – Ramhound Sep 29 '16 at 23:35
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change. – DavidPostill Oct 3 '16 at 9:27

I had this same problem but when trying to connect from mac os sierra to a windows host. I tried on a second macbook pro and same thing. Eentually I traced it back to the date and time on the windows machine. If the date/time is out by more the 1 hour then client connection fails. I synched the times to be the same and voila.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.