2

When running Help > Check for updates, Eclipse finds the 4.5.2 update. When updating, I get the following error:

An error occurred while collecting items to be installed session context was:(profile=_Users_username_dev_tools_eclipses_eclipse4.5.1.mars_Eclipse.app_Contents_Eclipse, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,com.gradleware.tooling.client,0.12.0.v20160425083245 No repository found containing: osgi.bundle,com.gradleware.tooling.model,0.12.0.v20160425083245 No repository found containing: osgi.bundle,com.gradleware.tooling.utils,0.12.0.v20160425083245 No repository found containing: osgi.bundle,org.eclipse.buildship.branding,1.0.15.v20160425-1638 No repository found containing: osgi.bundle,org.eclipse.buildship.core,1.0.15.v20160425-1638 No repository found containing: osgi.bundle,org.eclipse.buildship.ui,1.0.15.v20160425-1638 No repository found containing: osgi.bundle,org.gradle.toolingapi,2.13.0.v20160425083245 No repository found containing: org.eclipse.update.feature,org.eclipse.buildship,1.0.15.v20160425-1638 No repository found containing: osgi.bundle,org.eclipse.buildship.stsmigration,1.0.15.v20160425-1638

I did remove the Gradle plugin from Help > Installation Details > Installed Software, but I still see Gradle references in Help > Installation Details > Plug-Ins.

Extract of Help > Installation Details > Configuration:

com.gradleware.tooling.client (0.6.1.v201509101146) "toolingclient" [Resolved] com.gradleware.tooling.model (0.6.1.v201509101146) "toolingmodel" [Resolved] com.gradleware.tooling.utils (0.6.1.v201509101146) "toolingutils" [Resolved]

This is on OS X El Capitan 10.11.4

2

I was able to fix this issue by doing:

  1. Help > Install new software > Available Software Sites > Add a trailing slash to URLs that don't have one
  2. Check for updates again.

This solution was taken from item #2 of this answer : https://stackoverflow.com/a/15897080/2223027

1
  • Worked for me, trying to install m2eclipse-scala. – manuelvigarcia Feb 16 '17 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.