3

I have recently found out that VLC had a desktop mode and well i saw that some people was using this to have the ISS Livestream as their desktop background.

VLC was started inside Desktop Mode and the stream http://iphone-streaming.ustream.tv/uhls/17074538/streams/live/iphone/playlist.m3u8 loaded perfectly but instead of going on one screen its spans both of them, Is it posible to have it displayed on one monitor only instead of spanned across?.

Image: Screenshot of what vlc looks like when used as desktop background

Operating System: Windows 7 Ultimate 64bit

Monitors: 1920x1080 and 1366x720

  • It's in "desktop mode" so it covers your whole desktop. You should edit your question and tag it with the OS you're trying to accomplish this on. – Ƭᴇcʜιᴇ007 Apr 27 '16 at 17:57
  • @Ƭᴇcʜιᴇ007 Okay i added it, thanks for that - hopefully someone will have a idea what i'm rambling about. – Callum Apr 28 '16 at 17:19
2

There are to ways how you can fix it.

1. Using command line

Open cmd.exe and go to VLC path (it is usually in C:\Program Files (x86)\VideoLAN\VLC). Now run following command:

vlc --video-wallpaper --align=2 --qt-start-minimized http://iphone-streaming.ustream.tv/uhls/17074538/streams/live/iphone/playlist.m3u8

This will start your stream in wallpaper mode --video-wallpaper and only with a systray icon --qt-start-minimized and will set the alignment of the video to the right screen --align=2.

For more help on command line options visit this VLC Wiki

--align={0 (Center), 1 (Left), 2 (Right), 4 (Top), 8 (Bottom), 5 (Top-Left), 6 (Top-Right), 9 (Bottom-Left), 10 (Bottom-Right)}

2. Using GUI

Go to ToolsPreferences, then select All in the Show settings group. This will show you whole bunch of available options. Then go to Video and search for Video alignment option. This options is set to Center by default. Change it to Left or Right in order to select your monitor in wallpaper mode. This worked for me. I hope it will do it for you too.

enter image description here

| improve this answer | |
  • 1
    Using --align 10 and turning of desktop mode on and off again it worked perfectly thank you so much! – Callum Apr 30 '16 at 0:10
  • 10 - bottom right. Probably because you have different resolutions on both screens. But I'm glad it's working for you. – Dimitri Podborski Apr 30 '16 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.