6

Host Machine:

  • Intel Core i3 3120M @ 2,50Ghz 2,50Ghz
  • 12GB RAM
  • Windows 10 Enterprise 64Bit
  • 750GB HD
  • 250GB SSD

Virtual Machine:

  • Windows Server 2008 R2 Enterprise
  • 4 virtual processors
  • 8GB RAM

I'm having some problems to create checkpoints on my VM. When i try to do it, Hyper-V goes until 19% of the creating progress, and then this error screen appears:

Error1

I've analyzed Event Viewer's logs, and on the Hyper-V Worker > Admin section, it shows the following messages:

'PNSP2013' could not initiate a checkpoint operation: %%2147754996 (0x800423F4). (Virtual machine ID 69EAA8C6-E8E9-4585-97AE-5633F400BB89)[

And I also collected VSSDiag's log, which contains no relevant information (at least for me)

A VSS writer has rejected an event with error 0x800423f4, The writer experienced a non-transient error. If the backup process is retried, the error is likely to reoccur. Changes that the writer made to the writer components while handling the event will not be available to the requester. Check the event log for related events from the application hosting the VSS writer. Log:

Operation:    PostSnapshot  Event
Context:
Execution Context: Writer
Writer Class Id: {b2014c9e-8711-4c5c-a5a9-3cf384484757}
Writer Name: NTDS 
Writer Instance ID: {2b09511a-25fd-47cd-929f-4f1f60cc1594}
Command Line: C:\Windows\system32\lsass.exe
Process ID: 636NTDS

Some important points to consider:

  1. I have enough space on the SSD drive to store the checkpoint file.
  2. I've tried to stop all non-Microsoft services on the VM and restart it, but no success
  3. If i turn off the VM, the checkpoint can be created with no errors.
  4. According to this article, i've also checked the KB982018, and it's already installed on the VM.

I can't figure out what the hell is going on... Some help?

15
  • Is the Server VM a Domain Controller? If you run vssadmin list writers in the VM, what does it report for the NTDS VSS writer's 'State' and 'Last Error'? What does automount run from within diskpart report? Apr 27, 2016 at 17:21
  • @Ƭᴇcʜιᴇ007 Yes, it is a Domain Controller. About the vssadmin, when i try to make the checkpoint, the NTDS says: Failed on the State and "Non retryable error" on the "Last Error". When i run diskpart then automount, it says: "automatic mounting of new volumes enabled" Apr 27, 2016 at 17:57
  • Just to make sure, have you tried rebooting the host? Also, in the registry at HKLM\Software\Microsoft\Windows NT\CurrentVersion\ProfileList do any of the listed profiles end with .bak? Also you say you have enough space to store the snapshot, but exactly how big is the VM and how much space do you actually have free on the host's system drive? Apr 27, 2016 at 18:00
  • @Ƭᴇcʜιᴇ007 Yes, i've already rebooted, and no way. After rebooting, all VSS writers went to Stable state (including NTDS) but when i try to make the ckeckpoint, the error occurs again. About the registry key, no profiles are listed with .bak Apr 27, 2016 at 18:05
  • Have you got SQL server installed on there as well (helpfully not, it's a DC, but you never know ;) )? If you spin up a new VM, and install Server 2008 R2 (and nothing further). does it exhibit the same problem? Apr 27, 2016 at 18:08

4 Answers 4

8

This is a known issue for pre-2016 DCs running in VMs on 2016/Win10 Hypervisors.

The problem is the new Production Checkpoint architecture. If you change the Checkpoint type to Standard in the VM's settings, the Checkpoint will succeed.

6
  • 2
    Damn dude, you're a freaking genius! Thank you SO much for this. Apr 12, 2017 at 18:06
  • 1
    @VictorAlencarSantos — Not really... I just happened to stumble onto the answer, that's all. And spent a day futzing with it. But thanks :-)
    – InteXX
    Apr 12, 2017 at 18:31
  • 1
    You've just saved me hours of wasted time, thank you so much.
    – Basic
    Apr 27, 2018 at 20:12
  • @Basic: How do you know it was hours if you didn't waste it? ;-)
    – InteXX
    Apr 27, 2018 at 22:22
  • @InteXX Because I wouldn't have started looking there. I thought ti was an issue with Shadow Copy on the volume itself, eg a disk issue.
    – Basic
    Apr 28, 2018 at 17:52
1

I had this problem and none of the above worked. I found this solution elsewhere on the internet, which did work.

icacls C:\YourPath\YourVMFolder /grant “NT VIRTUAL MACHINE\Virtual Machines”:F /T
0

I just want to add that I fixed this issue with a brand new setup with Hyper-V 2019 and Veeam 10.

The issue I was having was that the backup and checkpoint would get to 7% or 50% and freeze. The backup job froze, then VM guests froze. I was not able to gracefully shut down the VM guests. When I tried to reboot the Hyper-V host, it froze.

  • New Dell PowerEdge Server stand alone server.
  • New Windows Server 2019 Hyper-V (stand alone)
  • 3 x New Windows Server 2019 VM guests
  • 1 x New Ubuntu 20.04 Server VM guest
  • Veeam Backup & Replication 10.0 Community Edition.

After changing the checkpoint type to Standard in the VM's settings in Hyper-V manager, then rebooted all VM guests and VM host, I ran the backup again and the checkpoint succeeded in a few seconds and the backup ran without any problems.

0

What ended up fixing it for me. Navigate to folder containing the Hyper-V VHD files. Go to folder Properties>Security>Edit Add INTERACTIVE and SERVICE and give them Full control. Checkpoints of running VMs now run without error

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.