1

I was playing a game on Windows 10 when I got a BSoD telling me "Critical process has died", collecting the info took incredible long so I shut the laptop down via ACPI (waited for nearly 20 minutes before this). After that I tried to restart but the PC just hung on the boot logo so I tried to go into BIOS to change boot-order to be able to launch Kali from a external drive. After waiting 2 minutes after pushing the BIOS key on boot I was actually able to access BIOS and enable boot via DVD. When I booted up Kali I got this:

ata6: COMRESET failed (errno=-16)
ata6: link is to slow to respond, please be patient (ready=0)

After displaying this several times it gives me this:

ata6: limiting SATA link speed to 3.0 Gbps
ata6: COMRESET failed (errno=-16)
ata6: reset failed, giving up

Once booted I've no access at all to the SSD. After some research I found out that it could be either the SSD itself or the motherboard, the problem is that I've still warranty on this laptop so I don't want to open it because that would void it. Is there any way to find out if it's the motherboard or the SSD which is broken? And, is there anyway to get the SSD working even if its only on very limited speed so I could use some live system to mirror the drive without needing to disassemble/voiding the warranty of the laptop?

EDIT When waiting long enough GRUP shows up and trying to boot Windows (Linux is on another drive that works normally) it gives me an error about timing out when trying to read boot files, which means that the SSD still seems to work in some way (?)

migrated from unix.stackexchange.com Apr 28 '16 at 14:25

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

  • If the SSD has failed there is no getting it working. It sounds like a hard failture, if it was only a "soft" fail, formatting the drive would likely work. A motherboard typically does not function, then randomly fail, those are typically more storage related problems. Motherboard failures are typically more releated to intial power-up/power-down stages – Ramhound Apr 28 '16 at 14:34
  • @Ramhound The SSD seems to work as it detects the Windows Boot Loader located on the SSD (together with my GRUP+Linux installation located on my secondary drive) – Steffen B Apr 28 '16 at 14:36
  • you probably have an UEFI. This is probably the place where your windows boot loader comes from. for me it looks like your SSD does not respond at all. many notebooks allow to remove the SSD without voiding the warranty. Maybe check if this is possibe and then try to use the ssd in another pc. – masgo Apr 28 '16 at 14:44
  • If the laptop is under warranty does it matter if its the SSD or the motherboard though? In either case you can't open the laptop, if its the motherboard, it can't be replaced by you. If it is the SSD, while you could easily replace that, apparently it would void your warranty. Unless you can remove the SSD, there really isn't a way, to tell which failed – Ramhound Apr 28 '16 at 14:44
  • @masgo I can't access the SSD without voiding the warranty, only the secondary drive, which I already did. – Steffen B Apr 28 '16 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.