3

I already made this question on the AskUbuntu community, but had no good answers/help.

So, here I am.

I am trying to install Lubuntu on my Asus EeeBook X205TA that came with Windows 10 Home (32bit) pre-installed.

Here is the information that may help you help me.

BIOS (model X205TAW) options:

enter image description here

When I press the UEFI: SanDisk option the screen turns black for a second and comes back to the boot menu. Changing the boot order in BIOS does not have any effect.

Here are the things I tried already:

  • Intense Googling for solution;
  • Used Rufus USB tool and the one suggested by the Ubuntu website to burn the ISO into the stick. I used all the combinations possible with the Rufus software (partition schemes);
  • Tried Lubuntu, Ubuntu and Xubuntu (32bit and 64bit) distros, none worked;
  • Using the Windows 10 Media Creation Tool the PC boots the USB without problem and enters the Windows Setup;
  • Updated the computer bios;
  • Tried to install plop boot manager, no success ("Can't get partition information. 144" Error);
  • Tried with several USB sticks and ports (BIOS do not recognize the micro SD slot, even with the distro in it);
  • Disabled the secure boot menu. Basically, I tried almost every combination possible in the BIOS settings. The only thing I didn't touch was the Key Management sector;
  • Updated the drivers of the computer;
  • Made a full reset of the Windows 10, using the Windows 10 tool.

These are the things I remember, if I remember more I will update the question. Any extra information, just ask. I will be online for the next couple hours.

Thanks in advance.


UPDATE 04/05/2016

I've made it work. Sort of. WiFi and sound drivers not working. I ended up reinstalling Windows 10 back...

So, following the suggestions on the answer of @TomaszS, and some crazy tweaking by my part.

Here is what I did:

  • Downloaded the 64-bit version of Xubuntu (worked with Ubuntu also);
  • Used Rufus to put the distro into an USB stick, using GPT partition mode;
  • Downloaded this and this;
  • Copied both to the boot/EFI folder on the USB stick that I was using;
  • Copied the same files on the previous step again and changed the names of it to the original ones. The ones that came with the Ubuntu/Xubuntu download, so it would replace these files (32-bit versions instead of 64-bit) for the installation (I guess, don't really know. It just worked);
  • Delete the original files on the boot/EFI folder;
  • Deactivate the secure boot etc. to make it boot from the USB;
  • Let the installation download updates during the install;
  • Wait to complete and that is it!

UPDATE 05/06/2017

Finally got it to work with Arch Linux and a little bit of wiki reading. Following these guides I made it work (SOUND DOES NOT WORK, unfortunately):

If you give these guides a good read you will get an Arch Linux running (withou sound). As far as Ubuntu goes, not sure if it is possible.

  • In the Boot options menu, do you have anything other than UEFI? – ozbek Apr 29 '16 at 1:22
  • I have the Windows Boot option. Like in this pic i.imgur.com/Iex2DH1g.jpg – meyer1994 Apr 29 '16 at 1:33
  • Yes, I already saw that pic. I meant, if there are any other options for Boot Option #1 – ozbek Apr 29 '16 at 1:40
  • There is just the disable and Windows Boot Manager options. – meyer1994 Apr 29 '16 at 2:12
3

I looked up your processor and it is actually a 64-bit processor. The thing with these smaller netbooks that have a intel baytrail is that they often have 64-bit processors but 32-bit UEFI firmware. Basically you need a 64-bit Linux distro with a 32-bit bootloader for it to work because as far as I know, 32-bit Ubuntu doesn't have an .EFI file and the 64-bit Ubuntu doesn't have a 32-bit .EFI.

This is what I had to do for mine: http://liliputing.com/2013/10/booting-ubuntu-asus-transformer-book-t100.html

You need use this 32-bit bootia32.efi boot file: https://github.com/hirotakaster/baytail-bootia32.efi and put in in EFI/BOOT/bootia32.efi on your 64-bit live USB drive for it to work.

It's really a pain in the butt. I ended up just sticking with windows 10 and running lubuntu in virtualbox because support wasn't that great for my T100TAF.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.