1

EDIT: Any type of power saving thing is DISABLED and is currently not active on my Computer, this includes NVIDIA BatteryBoost and Windows Power Options. I am 95% sure that Power Savings is not a factor in this problem (the 5% is some application that I may have that does it without me knowing, excluding GeForce Experience) although there still is a chance that it could be that.

It's as basic as that. I have an Asus ROG G751JL with an Intel i7-4720HQ CPU and GTX 965m GPU.

For some strange reason, I've noticed that my PC loves to CAP the framerate when the GPU can not maintain a certain Framerate so it locks the framerate at something and uses less of my GPU.

I'm sorry if I sound vague but what I am saying is this: let's say The Forest is currently running at (true story) 43 FPS, 2-5 seconds later the framerate locks at 40 and never goes up or down no matter how hard I try. I have GPU-Z on my secondary monitor and I see that GPU usage is never at 100%. I understand that not all games use the GPU's full raw power but what's weird is the GPU usage is always jumping between 76-96%, the lower usage, lower FPS obviously.

I wonder if this is the NVIDIA GameReady driver at work keeping a stable "good looking" FPS, or it's my laptop itself. I tried switching the power mode to 'Prefer Maximum Performance' in the Control Panel but all that does is force the GPU to run at its full turbo boost clock and doesn't change the FPS lock that happens to my games.

This happens to ALL my games, even simple generic 3D applications. Any help will be greatly appreciated. I will look at this question for the next few weeks daily. Thanks for any replies (even if they are no help at all)!

4

Are you using BatteryBoost?

NVIDIA BatteryBoost extends battery life by limiting the maximum frame rate. This reduces the load on the GPU and therefore power consumption. You should be able to adjust or disable this feature in GeForce Experience.

  • Indeed, it sounds a lot like power management sneaking its way in. Remember your Windows power profile could also be affecting the performance, although not in the same way. – Thor Apr 29 '16 at 7:22
  • No, BatteryBoost is disabled, I even disabled the .dll because I don't need it. – Adam Lopez May 1 '16 at 1:25
0

For me it had to do with the laptops G-Sync.

Games run much faster and responsive (even tho screen tearing happens now)

Open "Nvidia control panel", click "setup G-Sync" and uncheck the box "Enable G-Sync" and click apply.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.