5

It happens on my desktop randomly, the more i use the connection the more likely to happen (i.e. the moment when I load a new, playing a videogame with constant connection). The connection drops for a few (or many) seconds and then resumes on its own.

Symptoms

  • Whenever this happens the internet connection stops (of course).
  • Whenever this happens I can't ping my router (192.168.0.1) from my desktop computer (Request timed out).
  • Whenever this happens I CAN ping my router from my laptop, laptop does not suffer from this problem, suggesting that the problem is with my desktop (maybe the wireless adapter?). EDIT: probably not the adapter, i connected a USB wireless adapter to my desktop and it still has the same issues. :(
  • Signal strength is at -65dBm, however my laptop with the same signal strength presents no problems.

How do i go about troubleshooting this? Any ideas?

Hardware

  • Wireless adapter: TP-LINK TL-WDN4800

  • Router: Lynksis E900

  • Windows 8.1

Things I've already tried

  • Resetting reset tcp/ip stacks with -netsh in CMD and flushing DNS to no avail.
2

Have you had a look at your ICMP?

Try this.

Start > Run > firewall.cpl >Advanced > Click "Settings" under ICMP

Only this should be selected. Allow incoming echo request

See if this helps out at all.

Edit

Another possible solution that i have read the firmware has issues. You may want to upgrade your firmware. But even better upgrade your firmware to DD-WRT

Instructions to do so are here. Linksys E900 Flash

The above is an option. You may get the best performance yet out of the router.

If you do not feel comfortable doing the above do some research.

You could also try this on the router as is.

Just login to the router should be 192.168.0.1 as you stated.

Find the page that has QOS settings and Disable WMM Support then save.

  • Disabled WMM and even though the problem is still there, it feels smoother now. I'm surprised that the issue seems to be with the router and not with my computer. I could not find "Settings" nor ICMP on here: puu.sh/oAiSs/1b22b2d9f9.png, am i looking in the right place? And lastly, given that the problem might be with the router then i might flash it into DD-WRT, I thought it wouldn't help because I thought the problem was with my PC but who knows. – Jose Apr 29 '16 at 18:51
  • @NetworkKingPing Oh and here's another bit of data, when getting 'Request timed out' on pinging the router from my desktop PC, I get really high latency from pinging the router from my laptop, it goes up to over 1000 sometimes, does this mean that the issue is with the router? – Jose Apr 29 '16 at 19:29
0

I was algo getting random timeouts, and sometimes even "destination host unreachable" while pinging my router. Here's the 3 things I did to fix this (I don't know which one made the trick though):

  1. In the router, changed the wireless channel from 1 to 11 because I detected interference from two other wifi networks.
  2. In the computer, manually override the DNS server to use OpenDNS.
  3. In my wireless driver setting I changed the following values:

    • 802.11n Channel Witdh from 20Mhz to Auto
    • Roaming Aggressiveness from 3.Medium to 5.Highest
0

Disabling WMM Support did the trick for me as suggested by @NetworkKingPin.
I was seeing 'request timed out' as well as quite high time for ping responses even when successful. And it wouldn't happen from the laptop. Only the desktop which was using a tp-link wireless adapter.
Something interesting to share for netgear users:
On the netgear router admin page I found the QOS setup page. In there the check box saying "Enable WMM (Wi-Fi multi-media) Settings" was already checked and it was disabled as-in there was no way to un-check it. What I had to do to uncheck it and save was
press f12 which opened the developer console -> 'inspect' the checkbox html element and manually allow it to be unchecked by removing the 'disabled' html attribute -> then click save button.
Hope it helps. This was too long for a comment thus posting as an answer. credits to @NetworkKingPin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.