0

This question already has an answer here:

I'm about to give up on installing .NET 3.5. I've tried almost everything now, but nothing seems to work.

  • Installing .NET 3.5 from my Windows USB installation via CMD doesn't work, it simply freezes after Image Version: 10.0.10240.16384 (Command used: dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs /LimitAccess). I have also tried copying the sources folder to my C drive and run the command, without succes. It should be noted that Dism.exe /online /Cleanup-Image /StartComponentCleanup freezes at the exact same moment.
  • Microsoft's installer doesn't work either. If I click the 'Install this feature' button it is stuck at the first phase (Where it's searching for the correct files if I remember correctly)
  • It cannot be enabled via the control panel, because it doesn't show up there.
  • (This might be a related issue) I cannot search for new updates, for some reason it just keeps searching without finding something or stopping. Nevermind, it found updates after ~2 hours.

I do not get any errors in all the ways that I've tried mentioned above.

marked as duplicate by Ƭᴇcʜιᴇ007 windows Sep 9 '16 at 15:44

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What edition are you running? Is it an upgrade installation? Are you absolutely certain it doesn’t appear in “Turn Windows features on or off”? It should be at the top of the list, “.NET Framework 3.5 (includes .NET 2.0 and 3.0)” – Daniel B Apr 29 '16 at 6:20
  • @DanielB I'm running on Windows 10 Home 64 bit. I've upgraded Windows 7 Home 32 bit to Windows 10 Home 32 bit, but later did a clean 64 bit installation of Windows 10. .NET Framework 3.5 does indeed appear in "Turn WIndows features on or off", my fault. But, when I check it's checkbox it does the same thing as the Microsoft .NET 3.5 installers do. – bramhaag Apr 29 '16 at 6:54
  • which AV suite do you use? – magicandre1981 Apr 29 '16 at 15:59
-3

https://superuser.com/a/947660/639488 Thanks to magicandre1981

DISM /Online /Enable-Feature /FeatureName:NetFx3 /Source:d:\sources\sxs /All /LimitAccess (replace D: with your mounted Win10 ISO) In some environment, DISM fails to fetch the file (Proxy, network policies). The DISM command takes the files from the DVD and you're fine.

Not the answer you're looking for? Browse other questions tagged or ask your own question.