10

Usually, right clicking on a file, selecting "Open with" followed by "Choose another app..." brings up the following menu which also includes installed apps, so that one may be set as the default application for the file type:

Program List

However, when trying to open a file using a Windows 10 Store app and the above method, the app is not listed. I can open the app, then open the file from within it, however this is less convenient.

So far I have tried to use the app's exe file (CodeWriter.exe), but this does not work without an app container.

To reitterate - I am not asking for suggestions for workarounds as I can open the file; I am specifcally asking how to set a store app as the default application when it is not in the above list.

9

The store app has to make the registration in this registry key:

HKEY_CURRENT_USER\SOFTWARE\RegisteredApplications

And then set the File association\Capabilities in another key, mentioning each file type it can handle. For example Microsoft Edge has the registration here.

HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages\Microsoft.MicrosoftEdge_25.10586.0.0_neutral__8wekyb3d8bbwe\MicrosoftEdge\Capabilities\FileAssociations

If you can post the export of RegisteredApplications branch, I can make a REG file which adds the FileAssociations info for that application.

With this done, the application should be normally displayed in the Open with.. dialog, as well as in Default Apps.

Update (May 3 2016):

You can use this REG file to add .CONF file type, using the same association setting for CodeWriter .txt file type.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages\ActiproSoftwareLLC.562882FEEB491_2.5.17.17_neutral__24pqs290vpjk0\App\Capabilities\FileAssociations]
".conf"="AppXea46y3k4tynme684q1dgefbnb0b9r8ec"

Pls note that you need to take ownership of the above registry key, add yourself full Permissions, then merge the REG file. Once done, reverse the Permissions to defaults.

Note: This REG file is valid for the current version (as of this post) of Code Writer. If you have any other version, make the modification in the appropriate key.

The key might have the following naming/numbering convention or similar.

ActiproSoftwareLLC.562882FEEB491_n.n.nn.nn_neutral__24pqs290vpjk0

10
  • Here's a link to the export, thanks for the help. May I also request you explain how you will add the FileAssociations in your answer for the benefit of anyone else who has the same question in the future. Link: onedrive.live.com/… – Unencoded Apr 29 '16 at 16:42
  • Sure. What are the file extension you want the program handle? – w32sh Apr 29 '16 at 16:50
  • Its a .conf file, (the netbeans.conf if you're interested) – Unencoded Apr 29 '16 at 17:13
  • Code Writer doesn't seem to install here.. the download/install process gets stuck. So making a REG might take some time... – w32sh May 1 '16 at 8:59
  • Then rather than take up your time, I'll just use another program and mark this as answered, thank you for your help though! – Unencoded May 1 '16 at 13:11
2

Easier way:

  1. If you know windows already has a default or it is common enough that it is recognized, skip to step 2. Otherwise, assign it a default manually (just pick a random app - it doesn't matter).

  2. Open settings, go to "apps" on the left, default apps

  3. Click on choose default apps by file type (it will be a link in your accent color).

  4. Find the file type you want it to open with - I couldn't find .conf by default but I assigned it to Notepad and then I found it.

  5. Click the app it is currently assigned to and select choose an app in the Microsoft store.

  6. Find the app you want to use. You most likely have it installed but if you don't, do it now. Done!

1
  • 3
    I followed these instructions and searched for the app in the store, and it was already installed. Now what? Closing the store window did not set the file association - it still says Notepad. – Jim K Aug 14 '20 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.