I'm using Office 2007 on Windows Vista and occasionally, when copying from Word to Excel, or text from a website to Word, I will get the hour glass for 10 + seconds and sometimes for about a minute. It should just be simple text and I don't understand why it takes so long.

  • 1
    What computer are you using? – Ivo Flipse Feb 10 '10 at 16:21
  • I'm seeing a very similar thing in Excel - pasting can take up to a minute to do nothing particularly complex with no major recalculation. Googling it seems to be not uncommon. – Jon Hopkins Feb 12 '10 at 16:02
  • 1
    I'm using an HP 8510w. – Nick Feb 17 '10 at 13:13
  • Is Word/Excel auto-saving in the background at the same time? – user45699 Aug 9 '10 at 23:09

Might be a virtual memory issue. Do you still have free memory? Some of the data that you can copy from Excel/Word can be extremely large because it saves all of the markup as well as the plaintext.


I've got three solutions to suggest (apart from going back to using an Abacus or your fingers).

First, try to select/copy/paste with a different web browser. I often find that if I try more than one browser I'll find one that handles the copy and paste of the custom background formatting better. For example, on some websites IE8 recently began replacing spaces in the filename with with plus symbols when downloading files. This extremely annoying problem was completely resolved by pasting the URL into Firefox and downloading the file from there.

Second, if you're using a firewall, try denying Word 2007 access to the internet. There's still some delay, but it's quicker.

Third, if it's not a massive table-formatted selection, try pasting into Wordpad (instead of Notepad), then copy and pasting from Wordpad to Word. Wordpad can often preserve significant portions of the formatted structure of your paste selection. Notepad will strip out ALL formatting and it may take you much longer to fix your pasted text from Notepad than the original wait pasting directly to Word.

Its a frustrating mix of no web-page formatting standards, browser/OS ability, and an overly-helpful Office 2007. Hope one of these suggestions makes things a little easier for you!


I had the same issue - copy and paste within Office 2007 (any program) was taking forever. 10 seconds or so. It turned out to be Photoshop Elements Backup that was running in background that was the problem. As soon as I killed that - Office worked fine.


Not exactly sure why it would be slow coming from Word or Excel, could be many reasons.

Copying text from a website to (newer) MS Office applications, on the other hand, is slow because the Office app will go out to the website you got the text from and try to determine how CSS (and other technologies) are affecting the appearance of text so that when you paste it it looks accurate to how it looks on the website.

In the past I've been known to just paste into Notepad from the Web and then copy from Notepad into Word. This avoids Word going and checking formatting on the web page, as it was pasted as pure text in Notepad. It's annoying though ;)

There are several Cut & Paste options in Word 2007 you may be able to play with to get it to behave a little more to your liking.

You can get to them like this:

  • Start Word 2007.
  • Click the Microsoft Office Button, and then click Word Options.
  • In the Word Options dialog box, click Advanced, and then scroll down to the Cut, copy and paste section.

I know this was an old link, but I just had the same issue. Photoshop Organizer was running in the backbround, and when I killed that process, cut and paste worked fine.


Open Task manager and start end application one by one til you find the one causing the issue. mine was dropbox good luck

  • This information does not provide an answer to the question – Fazer87 Jul 29 '15 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy