Whenever I try to watch the images of a patent in the USPTO site (example) using Firefox, the browser asks me to download the latest Quicktime, manually. This is totally strange because I already HAVE the latest plug-in (it even appears on my Firefox add-ons list).

In the past I have only been able to see patent images using Safari. But never with Firefox. Is it a USPTO problem or a Mozilla one? Is there a way to fix the problem?

edit: I can't see TIFF images neither with Internet Explorer (both 32-bit and 64-bit versions) nor with Chrome. All these browsers don't know how to open embedded TIFF images because they don't recognize the installed Quicktime plugin. A USPTO conspiracy to promote Safari? Come to think of it, I had this problem in my old computer as well. It had a 32-bit Vista OS, now I have 64-bit Windows 7. I hate TIFF and can't find Mozilla-specific information anywhere.. Arghh, am I the only one here with this freak problem?!

  • For those who want a different plug-in: see uspto.gov/faq/plugins/tiff.jsp – Arjan Feb 16 '10 at 13:10
  • from Arjan's link: "If you can view a screen that has a little rectangle with a red square, green circle and blue triangle in it, or if you get a message in your browser saying that some required software cannot be found, then you need to download and install a TIFF image viewer for your browser that works with our TIFF images." – quack quixote Feb 17 '10 at 8:18
  • Did you ever manage to solve this? – cregox Mar 2 '10 at 17:22
  • Nope. And no real answers to the Apple forum either. I guess I'll have to wait for a future version of Quicktime and/or Firefox to deal with the plugin issue. It seems to me that it hasn't installed correctly in my system. – Kensai Mar 7 '10 at 15:12
  • 1
    again, I don't think it's your installation. It happened at least to Arjan and me too. Now, that's QuickTime plugin issue just for displaying a TIFF file... Can you imagine what Apple is going through for dealing with FLASH?! :D – cregox Mar 12 '10 at 13:40

10 Answers 10


I had the same issue.

  • Go to the QuickTime control panel.
  • On the "Browser" tab, click on the "MIME Settings..." button.
  • Expand the "Images - Still image files" node and make sure "TIFF image" is checked.
  • Close the "MIME types" window and the "QuickTime Preferences" window by clicking on OK.
  • Restart Firefox.

After doing this, I could see the TIFF images on the USPTO site.

  • Bummer. I followed your instructions for both TIF and TIFF, restarted Firefox and still it asks me to download manually the plugin, which is the standalone Quicktime which I already have. I noticed in the Options --> Applications of Firefox that no TIF/TIFF handling is shown. Is this normal? – Kensai Feb 17 '10 at 22:00

I had same issue, running on Snow Leopard, Safari 4 and FF 3.6

In your example, the separated TIFF image can be found here, which behaves oddly in Safari but I still can't open in Firefox. In either way I can download the TIFF and see the file from my desktop.

Here you can test if the problem is in your plugin or the website. In my case, it was USPTO to blame. At very least they're quite outdated, but it's not an issue in the HTML itself. I'd bet it's on the .DImg script, but it could also be something in the plugin (mine is 7.6.3) or even FF 3.6. It's certainly some standard deviation issue, as the developer of another TIFF plugin for mac also had issues 2 years ago with FF 3.6 alone (unlike you, it seems).

Well, if you're on Windows, you can try alternatiff. Another option would be to install Google Docs Viewer extension, if you enjoy gDocs. I think there's still no fixes for this, and it does seem some people don't have that problem at all.

Updates to come as I find more info. intrigued

edit: Sorry, couldn't find anything more. This will likely be eventually fixed in future releases, I'd stick with using Safari or downloading the image in the meantime. Just as another side note, it also does not work on Google Chrome.

  • Thanks for the link to check where the problem is: "This page contains an embedded TIFF image compressed with LZW compression. You do not have a TIFF plugin installed or working." was the answer I got. So I guess the problem is in my Firefox. Any other guesses to fix Quicktime/Firefox before trying to install alternatiff? – Kensai Feb 17 '10 at 22:02
  • It's not in your firefox. You see, it happens same issue in mine. Anyway, I'm sorry, I couldn't figure out how to fix this and it seems like Arjan van Bentem is on top of it. Mind you if I ask why don't you just use Safari for such specific task, since you have it? – cregox Feb 19 '10 at 13:53
  • Heh, it's a matter of "principles". I HAVE to know what's going wrong and fix it. :) In the meantime, let me suggest freepatentsonline.com which is a powerful search engine for patents that provides with all patents in ready-to-download-and-print PDF files. Nevertheless, I would really love to know what went wrong with my Quicktime plugin installation. – Kensai Feb 19 '10 at 15:47
  • yeah, I'd like to know too. but I bet it's nothing different from what we expect. and it was nothing wrong with YOUR installation. I've worked enough with web standards and this is a tipical case of standard conflict. just like when you develop a web page you have to do it for IE and FF. – cregox Feb 21 '10 at 14:15

Update: it seems my email to the USPTO's webmaster already had the erroneous newlines removed from (some?) of the pages I tested earlier! That kind of obsoletes this answer -- let's see if it's indeed true, or just a coincidence.

The TIFF images are included in the web pages using something like:

<embed src="/.DImg?Docid=07574389&PageNum=1&IDKey=5D8E82D5603F
&ImgFormat=tif" width="570" height="840" type=image/tiff></embed>

This often/sometimes has a newline within the URL (and the type attribute is badly quoted as well). For Safari on a Mac, it is sufficient to get rid of that erroneous newline. Here's a bookmarklet to do just that (easily bookmark it from here):


Maybe this is just enough for Firefox as well, if the proper plugin has been installed following the instructions at USPTO's "Plugins - TIFF images". If so, then using Greasemonkey one can run the JavaScript automatically for each page.

Note that the URLs are not valid forever; when expired you might get another TIFF image telling you something like "Search Time Limit Has Expired. Please click on the Full Text button to return to the full text page." I've also seen images for which the server did not return a value for Content-Length, but I fail to find such images now. Maybe one out of multiple servers is behaving odd?

As an aside, at "Patent Full-Page Images" USPTO explains why TIFF is used:

PTO's full-page images [..] are stored and delivered at full 300 dots per inch (d.p.i.) resolution in an image file format called "TIFF," using CCITT Group 4 compression. This is the format which is required by the international standards to which all patent offices must conform. [..] Unfortunately, due to the volume of the image data, available funding, and other technical considerations, PTO cannot convert these images to a format more popular on the Web either permanently or by converting on-the-fly as they are delivered.

As a result, you must install and use a browser plug-in [..] in order to view these files directly. An alternative method is to use third-party software or services to view these images either directly or after conversion to another format, such as Adobe® PDF.

The plug-in you use cannot be just any TIFF image plug-in. It must be able to specifically display TIFF files using ITU T.6 or CCITT Group 4 (G4) compression.

So, one must use a plug-in. Or must one?

While USPTO may not be able to convert on the fly, why shouldn't you do that? If one manages to find an online TIFF converter then the bookmarklet is easily changed to use that...

  • The script didn't work for me, on firefox. It loads Q logo for a while and then QT says: "Search Limit Time Expired. Please click on the Full Text button to return to the full text page", whatever that "full text" means! :o – cregox Feb 19 '10 at 13:52
  • @Cawas, that's due to using old URLs, I think (like the ones referenced in this question and answers), so start afresh at patft.uspto.gov/netahtml/PTO/search-bool.html. (And I doubt the script is still needed to start with; like I wrote, it seems the erroneous newline has been fixed, but I did not get a reply to my bug report to USPTO's webmaster yet.) – Arjan Feb 19 '10 at 14:05
  • @Cawas, as an aside: note that the error message is actually a TIFF image as well. – Arjan Feb 19 '10 at 14:35
  • Haha, I only noted the error message was an image from quicktime, didn't thought it would be a TIFF! :) – cregox Feb 19 '10 at 14:57
  • I've already linked an online tiff conerter. it's google docs. ;) – cregox Feb 21 '10 at 14:17

I was also experiencing issues with USPTO using latest Safari.

My humble workaround (that works!) is that after I enter the patent number and then click to see the 'Images' I simply open the 'Activity' window (under Safari 'Window') and find the 'tiff' file and double click on it. Voilà, the images open in a new window.


I've been fighting with similar problems; the QT plugin for FireFox can't handle embedded MP3s ever since I upgraded past FireFox v3x to versions 4, 5, 6, etc. After doing a bit of research, it appears to be a 64-bit vs 32-bit issue: the QT plug-in is only 32-bit, and doesn't work properly in 64-bit mode. As to why QuickTime hasn't made a proper 64-bit plug-in yet, who can say? In the interim, if you switch to 32-bit mode, everything should display properly. This is no help to those of us designing sites that require this functionality (as the end-users will just assume it's a problem with our sites when the real culprit is QuickTime) but it should allow you to view the content you seek. Hope this helps!


Go to the Mozilla plugins site and download Aspator 1.103 – problem solved.


Commercial solution (some say it degrades after 15 days to a free viewer, else costs $49)
Accel ViewTIFF Plug-in:

Accel ViewTIFF is a Windows and Macintosh compatible plug-in and Active X Control for viewing TIFF images on most Internet web browsers.

Windows: Accel ViewTIFF works well with Firefox, Internet Explorer, Opera and Netscape. Macintosh: Accel ViewTIFF works well with Firefox, Opera and Safari ver 1 and 2*.

Users of Firefox 3.6 (Mac only) have reported a problem which we are ardently working to resolve.


Windows users can install the free Alternatiff plugin from here: www.alternatiff.com.

The suggested solution above about enabling TIFF in quicktime doesn't work anymore in Windows.


I just ran into this issue. I could not get Quick Time to work properly. I even reinstalled Quick Time with the latest. So I found this page at the USPTO: TIF Plugin Info. I was able to get Alternatiff and it installed very painlessly. It is 500K versus 36M from Apple QuickTime. It also worked! It is free and does not have Quicktime nagware about upgrading to Pro. It also does not have teaser options that cost money.

Alternatiff does what software is supposed to do: just work. No hidden installs, no rewriting a significant portion of your MIME types, just a simple TIFF viewer.


I found the aspator addon for Firefox, which seems to solve the problem of viewing USPTO patent images.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.