I have a problem with SSD (Intel 535 series). I've replaced with it a dvd-drive in my laptop (Asus L551LN). So now I have my old hdd in the old place and new ssd in the dvd-drive place.

The problem is Windows cannot find it. I tried to find it with volume management in the control panel. There is only one default hdd. And in the BIOS settings I can see the SSD. I even can set it as primary boot device.

Windows installer also cannot find this SSD. I've tried to use Intel Rapid Storage Technology driver as it mentioned in comments here - Windows 10 install don't recognize SSD. There is no result. I've tried to update Windows from 8.1 to 10. There is no result too.

The most interesting point is Ubuntu live CD can find SSD. More over, I've installed Ubuntu on this SSD and I can boot from that SSD and use Ubuntu. But Windows still ignore it.

So, short list of facts:

  • BIOS can find SSD
  • BIOS is up to date (version 209 from 8 Jul 2014 and here the latest version is 209 too http://www.asus.com/Notebooks/K551LN/HelpDesk_Download/)
  • Ubuntu LiveCD can find SSD and install Ubuntu on it (and I can boot it)
  • Windows 8.1/10 cannot find SSD.
  • Windows 8.1/10 installer also cannot find SSD
  • AHCI mode is enabled and I can't disable it (there is no options to switch from AHCI in the BIOS setup)
  • I cannot install SSD instead of default HDD in its port (it's hard do disassemble laptop to get HDD)
  • There is no drivers for SATA or something which would look as related to this issue in the ASUS support site

Since Ubuntu can find SSD and Windows cannot, I suppose there is some driver issue. But I can't find out which driver I should use to resolve it.

UPDATE: I noted very interesting thing. SSD is missing after reboot, but if I use sleep mode, after waking up Windows sees that SSD for a short time (something about one minute). It sees it size, but cannot create any files there. It just hanging and then SSD disapears.

sorry that it's not a screenshot - there were some wi-fi issues

  • While in Windows use Control Panel>Device Manager, when DM loads click the "scan for hardware changes" button, see if it finds the hard drive and lists it under Disk drives.
    – Moab
    Apr 30, 2016 at 14:36
  • @Moab no, there is nothing about my new SSD. I also formatted this SSD into ntfs now - windows installer still cannot find it.
    – Paul
    Apr 30, 2016 at 15:11
  • Give this a try (After booting into the installation disk, at the welcome screen press shift+f10 and a cmd window should pop up. Enter diskpart, then list disk. Your SSD should be listed here, note which disk number it is listed as. Enter select disk x (where x is the number of your disk). Then enter clean. Finish your install.) May 3, 2016 at 8:02
  • @NetworkKingPin I've tried it. My SSD just does not appears in that list. I've updated my question with some interesting find, maybe it would be useful for you.
    – Paul
    May 3, 2016 at 19:23
  • I have read a few posts saying the best solution when the computer does not recognize the SSD drive in the Optical Drive slot. That the best solution is to unplug the HDD. And then Install windows on the SSD as the computer will now recognize it. I know you do not want to take apart the laptop though. May 4, 2016 at 4:46

5 Answers 5


The issue is not in the SSD driver, but in SATA driver. You need to load Intel RST Driver into Windows installation.

Try downloading and extracting archive from here https://downloadcenter.intel.com/download/25165/Intel-Rapid-Storage-Technology-Intel-RST-RAID-Driver on a flash drive according steps here: http://h30434.www3.hp.com/t5/Notebook-Operating-System-and-Recovery/SATA-driver-for-intel-HM76/td-p/3728090

Load the driver into Windows installation and I hope this will help you.

  • Hi! No, it doesn't help. I can choose drivers, but after applying Windows still does not see my SSD.
    – Paul
    May 3, 2016 at 19:18
  • I've updated my question, maybe it could be useful.
    – Paul
    May 3, 2016 at 21:11
  • The only idea I have, is to update SSD firmware with latest version from Samsung... May be you will need another PC to do this...
    – joro
    May 9, 2016 at 15:08
  • why should I update Intel SSD with Samsung firmware? And still - Ubuntu does recognize my SSD without any problems.
    – Paul
    May 10, 2016 at 12:07
  • Sorry, I mean update SSD (Intel) firmware. (I had in a issue with Win 8.1, which did not exist when I was with Win 8. And a firmware update helped me.)
    – joro
    May 10, 2016 at 12:48

I had exactly the same situation (Windows 10 installer does not recognize SSD and Ubuntu does, SSD is missing after reboot) with ASRock Q1900-ITX motherboard. I also tried different drivers to load from the installer without any luck.

The solution for me was to change the SATA port. My motherboard has two black and two grey SATA ports - obviously connected to different controllers. After I changed from black to gray, windows installer recognized the SSD.

  • I solved this issue with the same way by replacing default HDD with SSD. And I had to forget about HDD, because it looks like my notebook has only one port wich is able to work with disk drives.
    – Paul
    Jul 2, 2017 at 17:49

Windows seems to have problems recognizing SSD.

First things first - what is the size of SSD and what caddy make are you using?

Can you please post the layout of SSD as Ubuntu LiveCD sees the disk.

(Is it MBR style or GPT style, what partitions are on disk, etc.)

Windows expects a certain structure/layout of a GPT disk(at least):

  1. EFI System Partition (minimum 100 MB)

  2. MS Reserved Partition (size depends on disk size - eventually 128 MB)

  3. Basic data partition

Windows should not have problems recognizing MBR styled disk.

Also there is the choice (if hardware/firmware permits) to boot installation media two different ways:

  1. boot BIOS way (CSM enabled)

  2. boot UEFI way

If you boot BIOS way Windows installer expects MBR style disk for installation.

If you boot UEFI way Windows installer (64-bit Windows 7/8/10) expects GPT disk as destination for the installation.

You cannot boot Windows media BIOS way and install to GPT disk.

You cannot boot Windows media UEFI way and install to MBR disk.

Hope this helps.

  • SSD is 120 Gb and I using Espada SS95U caddy. I'll post layout of disk a little bit later. But out of my head I can say that by default there were no partitions there and I've created partition with GParted by myself. I tried to format disk into fat32 and ntfs, but there were no result.
    – Paul
    May 5, 2016 at 6:36
  • here is my partition layout i.stack.imgur.com/qH2iX.jpg I tried to make 100 Mb fat32 partition for uefi, but looks like it doesn't help. I set up this disk as GPT, but there is no effect for win installer.
    – Paul
    May 8, 2016 at 12:31

So, finally the only thing actually worked for me with Windows - to install SSD into primary slot (replacing default HDD in my laptop) instead of secondary one.


The 11th Generation Intel processors (Intel Tiger Lake) utilizes the new Intel Volume Management Device technology, which optimizes the storage devices' data processing effective and power consumption. If your computer is with the 11th Generation Intel processor, and then you experience that Windows cannot find any drives when installing Windows 10, please refer to the following troubleshooting steps. You also can refer to the statement of Intel. ** If your computer is with the 11th Generation Intel processor, you need to install The Intel® Rapid Storage Technology (Intel® RST) Floppy Drive it's help for me (11+ gen intel processor)**

  • Please add further details to expand on your answer, such as working code or documentation citations. Aug 28, 2021 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.