2

I am going crazy: I can not delete a folder inside the trash of my external drive.

The file path is /Volumes/drive_name/.Trashes/501/dir_name/

I tried

sudo rm -R /Volumes/drive_name/.Trashes/501/dir_name/ and

sudo rm -rf /Volumes/drive_name/.Trashes/501/dir_name/ in terminal but every time I get Directory not empty

The directory even shows up in my mac's trash when then the external drive is connected, but it does not empty:

enter image description here

How can I delete this folder from the trash? Thanks

  • 1
    Have you tried to find the process using it (fuser filename)? If that is not sufficient or you don't want to stop the process, you could try moving the file outside of trash. – Julie Pelletier Apr 30 '16 at 15:36
  • @JuliePelletier Thanks for your suggestion, I moved the folder from trash to the drive, now trash is empty but I am still unable to remove the folder. I can not find the process that's using it. – Ford1892 May 1 '16 at 11:11
  • 1
    Did you check fuser filename? If that doesn't identify the process in question, simply restart the computer. – Julie Pelletier May 1 '16 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.