3

I simply cannot find a way to stop LogMeIn Hamachi loading at launch. I use it rarely but don't want to un-install it yet it bugs me that it's there.

Launch Window

As you can see, LogMeIn Hamachi is not here...

It also happens to not be in the inbuilt preferences panel. Hmm, almost like they don't want it to not startup...

Looking in activity monitor there is

Appmon

I can only assume "launchd(1)" Means the process happens at startup so that's my only guess. Any help would be appreciated. Otherwise I'm tossing it out the window and keeping the installer till I need it again... Thanks! :)

  • I'd weigh up the amount of irritation at it always being there vs. the amount of irritation when you're on holiday in Ibiza/Aruba etc, try to get back to your home machine... & realise it's not running... :/ [I've done it, I now let it run] – Tetsujin Apr 30 '16 at 22:54
  • As the fact you're using it more I guess for it's intended purpose... I tend to use it only for creating an IP for (game) servers for me and a few friends to play on rather than renting a VPN. It more irritates me that they don't want you to turn it off, I'd rather have the option... :p And remember me from the other question? Tehe.... – Skidushe May 1 '16 at 22:56
5

The parent process (launchd, process ID 1) is the second process started by the machine (after kernel_task, ID 0). It loads up launch agents (that run at login for each user) and launch daemons (that run at boot for the whole system).

What you need to disable or delete is the launch agent corresponding to LogMeIn Hamachi. It’s in the folder /Library/LaunchAgents/. You can go to the folder in the Finder by using the menu item Go > Go to Folder, and pasting in the path.

If you delete the file com.logmein.hamachimb.plist in the LaunchAgents folder, then log out/reboot, you’ll find that LogMeIn Hamachi won’t load when you log in anymore.

Alternatively, you can disable the launch agent with the Terminal:

sudo launchctl unload -w /Library/LaunchAgents/com.logmein.hamachimb.plist
  • It's not in that folder?... – Skidushe May 6 '16 at 19:58
  • Edit: Nevermind, turns out there is two 'Library' folders, was in the other. – Skidushe May 6 '16 at 20:01
  • Hope it worked for you! If it does, don’t forget to mark the answer as accepted. – D Schlachter May 7 '16 at 15:37
  • As a sidenote, I followed the advice at hints.macworld.com/article.php?story=20110724044801607 and changed /Library/LaunchAgents/com.logmein.hamachimb.plist->OnDemand to KeepAlive so that the quit worked. – Ben Creasy May 29 '18 at 4:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.