I'm using Windows 10 and whenever I run PowerShell, I almost exclusively need to run it in Administrator mode, however the taskbar shortcut only seems to enable this by right-clicking on the icon and selecting Run as Administrator.

enter image description here

Is there a way to make the shortcut itself simply run as Administrator?

  • 3
    While it's not what you've requested, you could switch Command Prompt to PowerShell in "Taskbar Properties" (right-click on the taskbar) and then use [Win+X, A] key sequence to run PowerShell as admin (the A key may depend on locale).
    – rykien
    May 1, 2016 at 18:52

1 Answer 1


Yes, there is:

  1. Right-click the shortcut, then right-click Windows PowerShell and select Properties
  2. Click the Advanced button (on the Shortcut tab) and check Run as administrator
  3. Click OK twice.

enter image description here

  • 2
    Is the same possible for any other app? When I'm right-clicking my VS2017 taskbar shortcut, there is no Properties option. I'm using Win 10 1809 17763.194. Dec 27, 2018 at 16:15
  • @AlexanderAbakumov: Try using Shift + Right Click and make sure that the application is not running.
    – marco
    May 24, 2022 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.