1

I am getting this blue screen message on Windows 10 machine. (I cannot boot into safe mode or see any other Windows OS options.)

Recovery

Your PC/Device needs to be repaired

The Boot Configuration Data file doesn't contain valid information for an operating system.

File:\BCD
Error code: 0xc0000098

I have created a recovery drive and tried the Reset PC options. I get this information.

Reset this PC - remove everything

Unable to rest this PC. A required drive partition is missing.


Reset this PC - Keep my files

The drive when Windows is locked. Unlock the drive and try again.

I have run chkdsk on the C: partition but all looks fine.

As I upgraded from Windows8 using the online upgrade feature I do not have a Windows 10 disc to reinstall from. Can I use any Windows 10 disk including an OEM version to kickstart the rebuild? Or are there other tools available for fixing the BCD?

  • Run chkdsk on all partitions, it is complaining about the boot partition which is not C. – Moab May 2 '16 at 23:25
  • So how do I run chkdsk on BCD? – ChrisGuest May 3 '16 at 0:05
  • 1
    short story, assign the boot partition a drive letter, then run chkdsk on that drive letter, when done you can remove the drive letter. You should also check the smart data on that hard drive to see if it has failing sectors, which I suspect. – Moab May 3 '16 at 0:21
  • Thanks, I'll try that. This answer explains the process: superuser.com/a/989187/51443 – ChrisGuest May 3 '16 at 0:46
0

Fix "The drive where Windows is installed is locked"

Usually it is enough to repair boot files to fix problem,

but chkdsk will not harm ;)

And BTW once you activate Windows 10 on a computer you can clean disk and reinstall - OS will be activated automatically on same computer (MS keeps a database of activated Windows 10 per computer)

| improve this answer | |
0

This error usually occurs when a PC is configured without a WinRE partition, instead storing WinRE on the Boot or OS partition.

  1. Boot a Windows Install USB
  2. Once GUI loads, press SHIFT+F10
  3. BootRec
    • BIOS: BootRec /FixMBR && BootRec /FixBoot && BootRec /RebuildBCD
    • UEFI: BootRec /FixMBR && BootRec /RebuildBCD
  4. Reboot to Windows

It's recommended to move WinRE to its own partition: (ReAgentC)

  1. Open an Admin Terminal: WinKey+R > Open: powershell > CTRL+SHIFT OK
  2. Backup current WinRE.wim:

    1. Verify if C:\Windows\System32\Recovery\WinRE.wim exists:

      ls "C:\Windows\System32\Recovery" | FindStr /I "WinRE.wim" ; ls "C:\Windows\System32\Recovery" -Hidden | FindStr /I "WinRE.wim"
      
    2. If it doesn't:

      Xcopy /H "C:\Recovery\WindowsRE\WinRE.wim" "C:\Windows\System32\Recovery"
      
      • BIOS: May store WinRE on Boot partition: Mount Boot at Y: > Update WIM path

  3. Create a 650MB WinRE Partition: WinKey+R > Open: DiskPart > OK
    1. sel vol c
    2. shrink desired=665 minimum=650
      • WinRE partition must have 320MB free (WinRE.wim is ~300MB in size)
      • If this command fails, you will need to use a 3rd party partition manager to shrink the system partition by 665MB [RAW], as the formatted size should be 650MB.
    3. BIOS: cre par pri size=665 id=27
      UEFI: cre par pri size=665 id=de94bba4-06d1-4d40-a16a-bfd50179d6ac
    4. format fs=ntfs quick label=WinRE
    5. assign letter=z
    6. UEFI only: gpt attributes=0x8000000000000001

  4. Copy WinRE.wim:

    MkDir "Z:\Recovery\WindowsRE" ; Xcopy /H "C:\Recovery\WindowsRE\WinRE.wim" "Z:\Recovery\WindowsRE"
    
  5. Disable WinRE: ReAgentC /Disable
  6. Set Custom WinRE Path: ReAgentC /SetREimage /Path "Z:\Recovery\WindowsRE"
  7. Enable WinRE: ReAgentC /Enable
  8. Verify: ReAgentC /Info
| improve this answer | |
-1

Firstly: you can download the Windows 10 Installation media from the windows website directly. You will need to use a friend's computer to do this. You can then use the media creation tool to create an installation DVD or USB.

Secondly: Windows 10 sometimes shows errors like this on boot if it has recently downloaded a new update and there was not enough space on the C:\ partition to install the update during a system restart. The only option is to reformat the drive and reinstall Windows 10 - the Activation Key will be stored online by Windows, so you will not need this as long as you were using Genuine Windows.

I hope you had a backup of your data... Otherwise there are a number of ways you may be able to recover your files: by removing the drive from the computer and connecting it to another before formatting; by booting into Ubuntu from a USB drive; or by using a Windows Installation Disk to access the files via the "load drivers" button in the "repair" option.

Good luck!

| improve this answer | |
  • Yes, the data is backed up. Oddly I can mount the drive fine and copy it to another without any problem at all. – ChrisGuest May 2 '16 at 13:38
  • Re: Activation Key. Does Microsoft match it to the computer by the MAC address or something? – ChrisGuest May 2 '16 at 13:39
  • I believe it matches it by reference to the motherboard itself. I have had issues before when swapping out fried motherboards and have had to contact Microsoft directly to get the COA to be accepted as Genuine. As long as you have the backup data then reinstalling Windows should not be a problem. If you want guidance with the process then let me know - I have done this with so many machines now it is almost second nature. – Matthew May 3 '16 at 7:57
  • If you can mount the drive fine then this all points to it being an issue with a recent update installation. I think best to bite the bullet and reinstall the OS. Run all Updates before you transfer your backup data tho because there is a chance the problem could be caused by a conflict between an update and a hardware driver. – Matthew May 3 '16 at 8:00
  • Nothing in this answer is applicable to the issue experienced by the OP, nor is any of the information correct to the issue experienced... The correct utility to use for boot issues is BootRec, which is contained within all WinPE/WinRE images. – JW0914 Sep 12 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.