5

I'm on a MacBook Pro, running OSX 10.11.4 and browsing with Safari. I cannot figure out how to stop videos from autoplaying (particularly in Yahoo and CNN). It wasn't a problem in Yosemite, but since I reluctantly downloaded El Capitan, the security configuration block seems to have stopped working.

I'm doing the same thing I've always done: Safari tab > Preferences > Advanced > select "stop plug in's to save power", then Preferences > Security > Plug-in Settings > selecting plug in from currently open page, and selecting "Block". That was always sufficient in the past to stop autoplay from CNN and Yahoo. Now it doesn't work.

Did Apple deliberately reduce the functionality of this feature to appease website developers? Is there another way to stop these videos? Is it time to just scrap Safari and do all my browsing in Firefox or Chrome?

4
  • Have those sites recently swapped to using HTML5 players instead of Flash?
    – Burgi
    May 2, 2016 at 23:51
  • Maybe? I don't know how to check. Is it not possible to disable HTML5 videos? If so, can another browser do it?
    – Jas Max
    May 3, 2016 at 14:54
  • Can you provide a couple of example links and I'll take a look for you?
    – Burgi
    May 3, 2016 at 14:55
  • This one just played for me: cnn.com/2016/05/04/asia/… And this one too: cnn.com/2016/05/04/politics/…
    – Jas Max
    May 5, 2016 at 4:02

4 Answers 4

2

Check out Click2Plugin

https://hoyois.github.io/safariextensions/clicktoplugin/

And make sure "Load Plugin if HTML5 Conversion Fails" is untoggled (off).

0

The problem in your case is, you are using Safari on OSX which doesn't support any Extension. If you would switch to Chrome or Firefox there would be several ways to fix the problem what your'e describing.

Most Sites are not using Flash anymore, the only way is to disable Flash on your Browser like you said but on Safari there are no ways(at least i dont know one) to disable Autoplay directly or HTML5 Player.

0

Switch to Chrome. AdBlock will block all autoplay videos on CNN even with the recent changes. All you have to do is block the elements on the video frame three times. They embedded the video under two other elements to try to prevent AdBlock from stopping it. Of course, it didn't work. All it takes is six clicks. :)

The other solution is the Chrome "Disable HTML5 Autoplay" extension (https://chrome.google.com/webstore/detail/disable-html5-autoplay/efdhoaajjjgckpbkoglidkeendpkolai/related?hl=en). It stops autoplay cold in its tracks. Works great.

0

Install Adblock Plus extension.

Goto "Options" > "Add your own filters"

Add "*cnn.com*mp4|"

Add "*turner.com*mp4|"

These are currently working for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .